Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Installed php on windows server 2012 and then went to command line and php -i everything displayed like it should. Then went into iis and created the handler mapping for php via fast cgi at the server level, checked to make sure that it was available in a site I created on the server, but when I navigate to mysite/test.php all I get is a 404. Checked the php error logs and there is nothing new.

Suggestions, Ideas?

share|improve this question
    
Do you get a detailed message from IIS? Try this from the server machine if not and update with the actual 404 code (404.x). –  Nathan C Feb 7 at 20:43
    
@NathanC in IIS I went to error pages under error pages edit features click detailed error pages, restarted IIS and then re-navigated to a test.php page and all I get is the default 404 page –  kricket Feb 10 at 22:34

1 Answer 1

up vote 0 down vote accepted

Ok... figured it out, my firewall was directing requests on port 80 to an old server I had. The PHP page was not on that server which is why I was getting the 404 and when I enabled detail errors I was not getting new errors.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.