Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install gd using sudo yum install php-gd but I get the error below. I know I have ran into this problem before but I can't seem to recall how I got around it. Am I in the wrong directory? Did I update PHP incorrectly at some point? My brain seems to have turned off for the night and I can't figure this one out.

--> Processing Conflict: php55w-common-5.5.8-1.w6.i386 conflicts php-common < 5.5.0

--> Finished Dependency Resolution

Error: php55w-common conflicts with php-common-5.3.3-27.el6_5.i686`

Thanks

share|improve this question
    
Where did you get the other packages that start with php55w- and why didn't you prefix this one the same way? –  Michael Hampton Feb 8 at 2:35
    
Mostly because I have no idea what I am doing, unfortunately this was months ago and I don't recall where I got them. –  EvWill Feb 8 at 2:44
    
Ah okay, pretty easy fix. yum install php55w-gd then restarted apache. –  EvWill Feb 8 at 20:45

1 Answer 1

First of all you need check PHP version you have installed

# php -v

After this you need to find php-gd package for your version of PHP, cause yo are trying php-gd for PHP 5.5., but you (probably) have PHP 5.3.. So you can try:

  1. I assume you have REMI or CentALT repo installed, so just try installing pgp-gd from those repos.

    # yum install php-gd

  2. If you need newer version of PHP ==>> PHP GD:

    1. Remove Current PHP, the easy way is:

      # rpm -qa | grep php | xargs yum -y remove

    2. Install PHP version you need:

      # yum install php55w-common php55w-gd ...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.