Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up a new FTP server on Windows Server 2012 with IIS 8. When I upload an entire directory, many of the files are cut off and don't match the original file size. I haven't really compared them all but it seems like it might always be 2KB off. If I re-upload that individual file, it will work most of the time.

Here is my log for the latest file that had problems:

21 STOR Quotes.Core.dll 226 0 0 4b2ed740-5b0e-4bb0-8d82-19837385278e /quotes/bin/Quotes.Core.dll
21 PASV - 227 0 0 4b2ed740-5b0e-4bb0-8d82-19837385278e -
52547 DataChannelOpened - - 0 0 4b2ed740-5b0e-4bb0-8d82-19837385278e -
52547 DataChannelClosed - - 2148074264 0 4b2ed740-5b0e-4bb0-8d82-19837385278e -

The file should be 326,656 but ends up 324,800

  • This happens to all sorts of files (text, dll, image, config)
  • I've set my FTP client (FileZilla) to the transfer types Auto and Binary with identical results
  • I've also tried WinSCP
  • The server has port 21 open and ports 1024-65535 open for passive in Windows firewall
  • I've tried non-SSL and requiring SSL connections with a self-signed cert

I have 2 servers with almost identical configurations and have this problem on both but not any other 3rd party server. Any ideas?

share|improve this question
    
Sounds pretty weird. I know it's not ideal, but have you tried another FTP server application like FileZilla Server? I much prefer that over IIS FTP. –  Papa Feb 18 at 3:55
    
Yes, I get the same results with FileZilla Server. –  AndyMcKenna Feb 18 at 13:28
    
So it could be a Firewall issue...it could be interesting to test using active mode –  krisFR Feb 18 at 17:22
    
No difference between active and passive. I will be able to do some more testing at the end of the week. I also got out of my corporate network to ensure that there wasn't any outgoing firewall affecting it. –  AndyMcKenna Feb 18 at 17:40

2 Answers 2

Check this link as well -- known issue...

http://www.rackspace.com/knowledge_center/article/disabling-tcp-offloading-in-windows-server-2012

share|improve this answer
1  
It can be helpful to add more information to your answer instead of just linking it off-site. –  Drew Khoury Mar 6 at 8:36
up vote 0 down vote accepted

After speaking with my web host (Rackspace), they determined it was an incorrect setting on my NIC driver. TCP Checksum Offload was enabled and my truncation problems went away after disabling it.

More info here:
http://social.technet.microsoft.com/Forums/windows/en-US/7d129406-0602-4705-bf1f-7408d9f03846/tcp-checksum-incorrect-while-trying-to-ftp-file?forum=itproxpsp

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.