Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed vsftp, and then setup the config file as following:

anonymous_enable=NO

local_enable=YES

write_enable=YES

local_umask=022

chroot_local_user=NO

chroot_list_enable=YES

chroot_list_file=/etc/vsftpd.chroot_list

xferlog_file=/var/log/vsftpd.log

anon_root=/var/ftp

local_root=~

and in /etc/vsftpd.chroot_list, I added the users that I allow to log in.

and then restart service:

service vsftpd restart

then when I try to log in, I got this error:

ftp> open 127.0.0.1

Connected to 127.0.0.1.
500 OOPS: child died

I googled, but failed to find the answer.

Please help, thanks!

share|improve this question
1  
What is your OS ? –  krisFR Feb 11 at 19:22
    
ubuntu 13.10, using linode VPS. –  Hunter Feb 12 at 15:03
    
Can you try adding seccomp_sandbox=NO in your vsftpd.conf ? –  krisFR Feb 12 at 15:06
    
that works! Magic. Thanks very much! This problem bothers me for quite a long time. So, could you tell me what is this directive doing and why none of the tutorials I saw mention it? –  Hunter Feb 12 at 15:15
    
great! i've made an answer for it. –  krisFR Feb 12 at 15:58

1 Answer 1

up vote 1 down vote accepted

On Unbuntu 13.10, some has reported this error and have fixed it by adding :

seccomp_sandbox=NO in vsftpd.conf

It seems this is because :

With version 3.0 of vsftpd, a new feature was introduced and it appears that this has caused problems for a few people. That feature is seccomp sandboxing and it can turned off

Further infos :

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.