Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running a TFS (2013) Server inside a Windows Server 2008 R2 Hyper-V VM (hosted on Windows 8). Everything seems to be running correctly within the server; however, when I try to connect to the Web URI of the TFS Server, I can't seem to see the server.

The VM is using a static IP and is able to see the network. I can access the VM from the network (i.e. if I type \servername\ into explorer it shows the VM exists)

What can I try / do to diagnose or fix this issue? Is there something specific that I need to do to TFS to cause it to be exposed to the network via a VM?

There server is accessible from within the VM.

share|improve this question
    
Is the URL accessible on the VM itself? –  TheCleaner Feb 12 '14 at 14:05
    
Yes, it is - question updated –  pm_2 Feb 12 '14 at 14:23
    
Are you nesting VMs? –  DanBig Feb 14 '14 at 14:20
    
What error do you receive? –  MichelZ Feb 14 '14 at 14:29
    
No - not nesting VMs –  pm_2 Feb 17 '14 at 12:47

1 Answer 1

up vote 3 down vote accepted
+50

Make sure you have disabled the Firewall. Also, disable Loopbackcheck on the TFS Server:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. Right-click Lsa, point to New, and then click DWORD Value.
  4. Type DisableLoopbackCheck, and then press ENTER.
  5. Right-click DisableLoopbackCheck, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Exit Registry Editor.
  8. Restart the computer.

and Disable StrictNameChecking:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and click the following key in the registry: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
  3. On the Edit menu, click Add Value, and then add the following registry DWORD value: DisableStrictNameChecking
  4. Right-click DisableStrictNameChecking, and then click Modify.
  5. In the Value data box, type 1, and then click OK.
  6. Exit Registry Editor.
  7. Restart the computer.
share|improve this answer
    
+1 for disabling the firewall. I had a similar issue with my TFS2012 server I had setup as a VMware server. Shutting off the firewall fixed it. Another thing to check, can you access the Web-side of TFS through your browser? –  Lee Harrison Feb 14 '14 at 14:38
    
Yep - it was the firewall! Many thanks for your help! –  pm_2 Feb 17 '14 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.