Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi I am having problems installing postgres 9.3 on debian 7.1.

I have added the following:

deb http://apt.postgresql.org/pub/repos/apt/ wheezy-pgdg main

to the file /etc/apt/sources.list.d/pgdg.list

and added the appropriate key

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -

and run apt-get update and it does so successfully.

When i run apt-get install postgresql-9.3 i get:

postgresql-9.3 :     

              Depends: libldap-2.4-2 (>= 2.4.7) but it is not installable
              Depends: libpq5 (>= 9.1~) but it is not going to be installed
              Depends: postgresql-client-9.3 but it is not going to be installed
              Depends: postgresql-common (>= 142~) but it is not going to be installed
              Depends: ssl-cert but it is not installable

E: Unable to correct problems, you have held broken packages.

When i try to install the dependencies manually they all fail with the following message

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package ssl-cert is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ssl-cert' has no installation candidate

I feel like there is a compatibility problem as this seems to be too complicated to install. As i installed postgresql 9.0.8 on debian 6 so easily.

share|improve this question
    
Per wiki.postgresql.org/wiki/Apt, "Please report bugs on the pgsql-pkg-debian@postgresql.org mailing list, or open a bug in the Debian BTS" –  Craig Ringer Feb 13 at 3:42
    
You've got something wrong with your repositories, wheezy should definitely have ssl-cert as a package. Run apt-get update again and watch and make sure that it's able to connect to the regular debian repository? –  DerfK Feb 13 at 4:36
    
Thanks just re-installed debian wheezy and it works now. –  sqwale Feb 13 at 17:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.