Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have FreeBSD 8.0, and rebooting arise while zfs scrub was runing. Now when system booting it frezee at moment with ZFS version and ZFS pool version. I can't even login. The question : Is the scrub continue after reboot and i need wait while it finish or there is something wrong ? My system booting from Single User Mode but with out zfs. I just think that even if ZFS scrub continued i will have login promt. Thank u for your time

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It looks like your zpool.cache file is corrupted (I had a few of those in the early FreeBSD ZFS days). So as soon as the system try to access your pool, it stay stuck while trying to read its cached info.

Simply:

  1. boot as "single user" and do not launch or access your zfs pool
  2. go to the directory where is your zpool.cache file is (default is /boot/zfs/)
  3. move your zpool.cache file into something else (i.e. zpool.cache.BAD)
  4. execute a zfs import to have a list of the available pool, then zfs import <your_pool_name> to get it back

You will end with your zfs pool back in place and a new zpool.cache file will be created by the system.

share|improve this answer
1  
You might need to execute zpool import -f <your_pool_name> to get your pool back if the system consider it to be still active. –  Ouki Feb 14 at 18:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.