Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm receiving this error on "Linux Debian-70-wheezy-64-minimal 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1+deb7u1 x86_64":

Message from syslogd@hostname at Feb 14 02:54:51 ...
kernel:[81927.464687] Uhhuh. NMI received for unknown reason 31 on CPU 3.

Message from syslogd@hostname at Feb 14 02:54:51 ...
kernel:[81927.464743] Do you have a strange power saving mode enabled?

Message from syslogd@hostname at Feb 14 02:54:51 ...
kernel:[81927.464791] Dazed and confused, but trying to continue

After I receive this, the server just reboots.

I read on some other websites that it's related to CPU hangout? But they were not helpful resources.

share|improve this question
Did youu ever ressolve the issue, @user209395 ? – Sinthia V Aug 21 '14 at 15:55

This is almost always bad hardware. Run memtest for a couple of hours since that's the easiest thing to do. From there investigate your processor, add-in cards, motherboard, etc.

share|improve this answer
Do you have any other tools that I could run under the kernel? Since this is server machine that's not on any near of me.. – user209395 Feb 14 '14 at 16:08
Bad interrupts usually means "bad southbridge chipset". – Avery Payne Feb 14 '14 at 21:54
This just happened to me, all my terminal windows received those messages, but nothing bad happened and it hasn't happened again. Should I be worried? – Hubro Jun 2 '15 at 7:54

As mentioned above this seems to be hardware error,"NMI received for unknown reason 31 on CPU 3".NMI or non maskable interrupt is a hardware interrupt that processor can't ignore.NMI interrupt is usually for important task or to report hardware error

OS doesn't have much role to play,so here you can do these things

  1. Install mcelog rpm to get more deeper info

  2. If its a HP node,Change the HP BIOS option for the power saving mode to "OS Control" from any other mode configured such as "Dynamic Power Saving Mode" or "Static - High Performance" mode.

  3. Upgrade BIOS or firmware

But the best advice is to contact hardware vendor

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.