Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Using my Django app, I'm able to read from the database just fine. When the application didn't have permission to access the file, it gave me this error:

attempt to write a readonly database

Which made sense. So I edited the permissions on the file, so that the Apache process had write permissions. However, instead of it being able to write, I get this cryptic error:

unable to open database file

If it's useful, here's the entire output:

Request Method: POST
Request URL:    http://home-sv-1/hellodjango1/polls/1/vote/
Exception Type: OperationalError
Exception Value:    
unable to open database file
Exception Location: /usr/lib/pymodules/python2.5/django/db/backends/sqlite3/base.py in execute, line 193
Python Executable:  /usr/bin/python
Python Version: 2.5.2
Python Path:    ['/var/www', '/usr/lib/python2.5', '/usr/lib/python2.5/plat-linux2', '/usr/lib/python2.5/lib-tk', '/usr/lib/python2.5/lib-dynload', '/usr/local/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages', '/usr/lib/pymodules/python2.5', '/usr/lib/pymodules/python2.5/gtk-2.0']
Server time:    Sun, 23 Aug 2009 07:06:08 -0500

Let me know if a stack trace is necessary.

share|improve this question
add comment

7 Answers

up vote 34 down vote accepted

Aha, just stumbled across an article explaining this. Also Django have info on their NewbieMistakes page.

The solution is to make sure the directory containing the database file also has write access allowed to the process.

In my case, running this command fixed the problem:

chown www-data. .
share|improve this answer
    
This assumes you're on debian/ubuntu, if you're using CentOS you're going to want to use 'apache' instead of 'www-data' –  Luke Chadwick May 23 '13 at 6:44
add comment

see also http://code.djangoproject.com/wiki/NewbieMistakes#DjangosaysUnabletoOpenDatabaseFilewhenusingSQLite3

share|improve this answer
    
+1 Yup, that's the one - thanks. You may want to use a text label for your hyperlink instead of posting the full link. –  nbolton Jan 17 '10 at 18:54
add comment

Adding an operational user to the www-data group is working well on my test environment. Additionally I've put the sqlite3.db file into a separate subfolder, to be more secure.

Database file shall be owned by www-data

sudo chown www-data mysite/db_sqlite3/
sudo chown www-data mysite/db_sqlite3/my.db

My operational user hape gets a member of www-data group:

sudo usermod -a -G www-data hape

Allow database file write access to members of group www-data:

sudo chmod u+w+x,g+w+x mysite/db_sqlite3/
sudo chmod u+w+x,g+w+x mysite/db_sqlite3/my.db

As a result, the database can be accessed read+write by apache2-daemon (user www-data), without giving grant to the project root folder, and - on the other hand - the app can be run in dev mode by the operational user hape, e.g.

./manage.py runserver

also.

share|improve this answer
add comment

My solution to this was more like so. I didn't really want to change the ownership of this dir. (mostly because i use the pi user to do things like git)

/var/www/mysite $ ls -la sql*
-rw-rw-r-- 1 pi       pi       25600 Jan  2 22:57 sqlite.db

(or whatever db you are using)

where pi is the user that i created all the files in. (yes this is a raspberry pi)

Instead of changing of permissions to www-data, i found that I only needed to change the permissions like this:

sudo chmod 775 /var/www/mysite
sudo chmod 664 /var/www/mysite/sqlite.db
sudo usermod -a -G pi www-data

This gives group write access to the necessary files and adds the www-data user to the pi group.

Note: if you have logging, you will need to do this for the django logfile as well or apache won't like it much.

share|improve this answer
1  
I think you could've just added the pi user to the www-data group too. Also you could've just left the files as they are and used the command setfacl to add a access control list for pi on the files and or directories. –  slm Jan 3 '13 at 0:09
    
setfacl sounds like a potentially good option. It would be good to have this listed as an instructional answer. One issue i face is that I need to delete the .db file often in testing. When it gets recreated, it needs to be chowned again. –  SpiRail Jan 4 '13 at 9:30
    
See my answer for this question, serverfault.com/a/462970/2518. Is there something more I should add to that which would help? –  slm Feb 1 '13 at 23:28
add comment

The development server needs to be run as the same user who has write perms on the database folder, so if you originally created the database as root, you will need to be root when you run:

python manage.py runserver
share|improve this answer
    
While technically correct, running the server as root is a terrible idea -- It would be better to chown the database to the regular unprivileged user that normally runs the server... –  voretaq7 Nov 10 '12 at 8:52
add comment

Borrowed from SO question: http://stackoverflow.com/questions/4283132/apache-instance-user-permission-issue

Assuming files are owned by apache user to start:

% chown -R apache.apache /var/www/mysite

set ACLs for user/group pi:

% setfacl -d -m u:pi:rwx /var/www/mysite
% setfacl -d -m g:pi:rwx /var/www/mysite

% getfacl /var/www/mysite
# file: /var/www/mysite
# owner: apache
# group: apache
user::rwx
group::r-x
other::r-x
default:user::rwx
default:user:pi:rwx
default:group::r-x
default:group:pi:rwx
default:mask::rwx
default:other::r-x

You can tell there's an ACL with ls -l, the trailing '+' on the permissions bits:

# ls -la /var/www
drwxr-xr-x   3 apache   apache   80 26. Nov 12:43 .
drwxrwxrwt  15 root     root 360 26. Nov 12:40 ..
drwxrwxr-x+  2 apache   apache   40 26. Nov 12:43 mysite
share|improve this answer
    
Setting the owner/group to the apache process for the whole django project is a bad idea, no need to give unnecessary privileges. –  benjaoming Feb 1 '13 at 22:10
add comment

create a subdirectory in the working directory

mkdir db-folder 

create sqlite database in the subdiretory

sqlite3 db-folder/db.db

change owner for the subdirectory to www-data in debain or apache in centOS

chown -R www-data db-folder

and grab a cold beer coz your are done.

P/S: to check if the procedure was succesful

ls -l data-folder

you should see such

-rw-r--r-- 2 www-data root 4096 Jun 18 01:38 data-folder
share|improve this answer
    
If you're going to post an answer, please provide the answer that's substantially different to the other answers on same question. –  masegaloeh Jun 18 at 1:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.