Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

this is my first time working with IIS so bear with me here.

I set up IIS 6 on a Windows Server 2003 installation on an old PowerEdge 600sc to play around with.

I'm trying to link multiple domains to the site, using the free .tk domain names. For example SiteA.tk and SiteB.tk. I have my web content set up on D:/Web and the files for the two separate sites in subdirectories - D:/Web/SiteA and D:/Web/siteB. I have the default file iisstart.htm in D:/Web.

I have forwarding set up that forwards from my network IP [MyIP] to the server with no problem. So if I go to [MyIP] it pulls up the default page in D:/Web. If I go to [MyIP]/SiteA it pulls up the default page in D:/Web/SiteA, same for SiteB.

When I create a new site through IIS, for example for SiteA, I keep the default IP Address of the server, keep the TCP Port set to 80, set the home directory to D:/Web/SiteA and add host header values for www.SiteA.tk and SiteA.tk. Then when setting up the domain SiteA.tk, I tell it to forward to the [MyIP].

From what I understand of host header values, going to SiteA.tk should take me to the default page in my SiteA directory. But instead, it always returns the default page in my main directory, D:/Web.

I've made the pages unique - so the problem isn't that I'm confusing the same pages. I've also tried setting my domain name to forward to [MyIP]/SiteA and [MyIP]/SiteB, but it also returns the same old default page every time.

I bet this is something simple I'm missing - thanks for any advice in advance.

share|improve this question
    
I am confused because it seems your setup is correct. It could be just a browser's cache issue...maybe just try to clear your browser's cache... –  krisFR Feb 17 at 15:37
    
I tried that and it still returns the default page from D:/Web directory. I've also restarted IIS and restarted the server to no avail. –  Alex Klibisz Feb 17 at 21:26
    
Try to "shutdown" the default web site, then test again and let us know what happens –  krisFR Feb 18 at 23:52
    
I've tried that and deleting and recreating the default website. I'm left with the message "Bad Request (Invalid Hostname)" both when I try accessing the IP directly and the domain name. –  Alex Klibisz Feb 20 at 4:23

1 Answer 1

Found the solution.

I got rid of all of the header names, left the single IP as is, and set the port number to 7777 and 8888 for each of the two sites I was setting up within IIS.

I then went into my router config and setup port forwarding to those same number ports to the IP address of the server within the network.

Then I set my domains to forward to [MyIP]:7777 and [MyIP]:7777.

share|improve this answer
    
Let's say you have found a workaround not the solution...but if it suits you...... –  krisFR Feb 21 at 12:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.