Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Exchange 2010 instance where 2 different domains, Fabrikam.com and Contoso.com, are using the same server that has all 3 Exchange server roles installed, CAS/Transport/Mailbox. All of the clients are using RPC over HTTPS to connect over the open internet and none are members of the Exchange server domain, they are all geographically dispursed.

I have added a secondary OWA virtual directory with the following PowerShell command:

New-OwaVirtualDirectory -WebSiteName "Contoso.com"

I have configured each of these web sites with the appropriate DNS A record and SSL certificate:

mail.contoso.com
mail.fabrikam.com

So now the server has 2 IIS sites with 2 IP addresses, each bound to 1 of the SSL certificates. This all works well and as expected.

For the autodiscover record, I've configured each with an SRV record as follows:

_autodiscover._tcp.contoso.com  
priority       = 10
weight         = 10
port           = 443
svr hostname   = mail.contoso.com

and

_autodiscover._tcp.fabrikam.com  
priority       = 10
weight         = 10
port           = 443
svr hostname   = mail.fabrikam.com

The problem is, when the autodiscover XML is returned, the OWAUrl property is returning the URL for BOTH CAS URLs and not just the CAS url for the appropriate domain. I am aware you can use the AutoDiscoverSiteScope property and configure AD sites to control which URLs get displayed to specific IP ranges, however is it possible to return a URL based on which user or which mailbox database each user is in?

What are my options here to return the appropriate autodiscover configuration?

If anything is unclear please let me know and I'll update this question. Thanks in advance for your time.

share|improve this question
    
I'm not seeing what you're trying to accomplish - why not just one OWA and then redirect http://autodiscover.contoso.com/ to https://autodiscover.fabrikam.com/ ? Neither outlook nor Exchange minds what primary accepted domain the users have as their mail addresses –  Mathias R. Jessen Feb 20 at 0:19
    
First, if you reread, we aren't using autodiscover.domain.com at all. Second, these are vanity URLs and users in domain contoso.com don't want to see the fabrikam.com domain and vice versa. –  Nathan Rice Feb 20 at 1:02
    
I realize that you don't - I'm pondering why? I don't understand how changing/masking the OWAUrl changes the user experience in any way - where in Outlook does it show? I'm also pretty sure it can't be done by the Autodiscover service, you'ld have to rewrite the ouput on the fly –  Mathias R. Jessen Feb 20 at 2:35
    
Essentially these 2 companies are unrelated and sharing the Exchange instance. They don't want to see eachothers URLs. Some devices pick up the URL instances and are automatically redirected. iOS devices for example. –  Nathan Rice Feb 20 at 8:13

1 Answer 1

up vote 1 down vote accepted
+50

What you're looking for won't work - at least not in a supported way. If you've read the Exchange 2010 multitenancy guides - they specifically address this:

The URLs and hostnames configured returned to clients are the same across the system. It is not possible to configure tenant specific URLs to be returned via AutoDiscover. The recommendation therefore is to create generic and non-specific names that do not identify any specific tenants. .... It is not supported to modify or otherwise change the AutoDiscover the XML response returned to the client in any way for any reason.

http://www.microsoft.com/en-us/download/confirmation.aspx?id=28192 It's on p.33

share|improve this answer
    
Thank you for your reply. I will read this. –  Nathan Rice Feb 24 at 21:02
    
Looks like you are correct. Thanks for your reply. Bounty awarded. –  Nathan Rice Feb 24 at 21:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.