Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm reading a oracle guide for installing a Database on redhat 6, but i don't understand why oracle recommend to set the file-max system parameter and nofile in /etc/sysctl.conf

http://docs.oracle.com/cd/B28359_01/install.111/b32285/toc.htm#LTDQI127

So if i set nofile in /etc/security/limits.conf for oracle user, why i need to set a limit for the system wide?

Oracle parameters example in /etc/sysctl.conf:

fs.file-max = 65536  <------ UMMMMMMM ---->
kernel.shmall = 2097152
kernel.shmmax = 2147483648
kernel.shmmni = 4096
kernel.sem = 250 32000 100 128
net.ipv4.ip_local_port_range = 9000 65500
net.core.rmem_default = 262144
net.core.rmem_max = 4194304
net.core.wmem_default = 262144
net.core.wmem_max = 1048576

Oracle parameters example /etc/security/limits.conf:

oracle           soft    nproc   2047
oracle           hard    nproc   16384
oracle           soft    nofile  1024
oracle           hard    nofile  65536 <----- UMMM so the hard limits of the oracle users is equal to the maximum system wide ---->

I think this oracle parameters are incorrect, but i would like have some feedback about this.

share|improve this question

2 Answers 2

The documentation says:

Verify that the kernel parameters shown in the following table are set to values greater than or equal to the minimum value shown. The procedure following the table describes how to verify and set the values.

So you dont have to set the system-wide limit to that value, just at least that (personally I think the system wide limit there would be too low).

Setting the per-user limit to 65536 seems reasonable.

share|improve this answer
    
if don't see any reason to the system wide limits, if set a limit on oracle user, why oracle says to limit the system wide limit? –  c4f4t0r Feb 20 at 18:56
    
The system values if already set need to be at least what is shown. You don't need to add lines, mentioned in the notes as Include lines only for the kernel parameter values that you want to change. –  Brian Feb 20 at 19:06
    
@Brian my problem is, many people doesn't read the notes and just copy and paste the above parameters –  c4f4t0r Feb 20 at 19:31
    
/people/c4f4t0r/ –  Matthew Ife Feb 20 at 19:35

When Oracle verify this values, it's verify with superuser, i had this problem when i installed Oracle 11 in Red Hat 6. I fixed problem when I configured this value in /etc/sysctl.conf

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.