Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to use Integrated Lights-Out 2 (aka iLO)'s Virtual Media (which is Java based applet) and I'm getting following error(s):

  • Application Blocked by Security Settings
  • Your security settings have blocked a self-signed application from running

info:

$ rpm -q jdk
jdk-1.7.0_51-fcs.x86_64
$ cat /etc/redhat-release 
Scientific Linux release 6.5 (Carbon)
$ uname -a
Linux wcmisdlin02.uftmasterad.org 2.6.32-431.5.1.el6.x86_64 #1 SMP Tue Feb 11 13:30:01 CST 2014 x86_64 x86_64 x86_64 GNU/Linux
$ 

So, I went to Why are Java applications blocked by your security settings? and added URL to the Exception Site list - still no luck(

How do I pass that self-signed application block?

share|improve this question
2  
Terrible, right? –  ewwhite Feb 20 at 23:26
    
I'm pulling my hair! –  alexus Feb 20 at 23:26
    
I'd recommend running the firmware update from the OS and trying again. –  ewwhite Feb 21 at 17:02
    
Try Java 6 instead. We've found a similar situation and workaround recently –  Tom O'Connor Feb 23 at 11:49

2 Answers 2

I've been having this problem a lot with Java update 51. Others have, too.

You've tried adding the URL to your exceptions list. Have you tried a different browser?


For an ILO-specific solution, if you just need access to an ISO image, you can mount it via a URL through the ILO SSH interface. It also makes sense to update the firmware of your ILO. You can do this from the operating system if the web interface is not working for you.

</>hpiLO-> vm cdrom insert http://dev1.brazzers.com/centos/6.5/boot.iso
</>hpiLO-> vm cdrom set boot_once
share|improve this answer
    
While this solution may work for some, unfortunately it won't work for me as I do not have public http server, my ISO file is stored locally on my computer. –  alexus Feb 21 at 0:18
    
Oh, can you update your ILO firmware as well? That may help. –  ewwhite Feb 21 at 0:41
    
that's exactly what I'm trying to do) –  alexus Feb 21 at 0:46

I hate suggesting this because I'm generally on board with Default Deny policies but I eventually gave up trying to make the Exception List work for all of different web applications and browser combinations and just set Java's Security Level to Medium.

From the documentation: http://www.java.com/en/download/help/jcp_security.xml

High

This is the minimum recommended (and default) security level setting. Applications that are signed with a valid or expired certificate and include the Permissions attribute in the manifest for the main JAR file are allowed to run with security prompts. Applications are also allowed to run with security prompts when the revocation status of the certificate cannot be checked. All other applications are blocked.

Medium

Only unsigned applications that request all permissions are blocked. All other applications are allowed to run with security prompts. Selecting the Medium security level is not recommended and will make your computer more vulnerable should you run a malicious application.

share|improve this answer
    
I put mine on Medium yet that didn't resolved my issue. –  alexus Feb 21 at 0:17
    
@alexus - Dang! We're not using iLO here but this did work for other apps. Sorry. –  kce Feb 21 at 0:23
    
it works for other apps for me as well, just not for iLO( –  alexus Feb 21 at 0:30
    
The medium setting works for dell idracs. Dunno why iLO would be any different. –  Grant Feb 21 at 3:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.