Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I setup a samba4 test server on Debian Wheezy using the packages from sernet. Basic configuration was not too complicated and it seems to have set up a running server. I can successfully kinit Administrator, or id Administrator, getent passwd etc. all through the nsswitch winbind. Host resolution for the ldap and Kerberos servers also returns the localhost. Yes, it seems to run like a charm, until you want to do something with it.

root@nfs4:~# net ads info
ads_connect: No logon servers
ads_connect: No logon servers
Didn't find the ldap server!
root@nfs4:~# host -t SRV _ldap._tcp.mgr
_ldap._tcp.mgr has SRV record 0 100 389 nfs4.mgr.
root@nfs4:~# smbclient //nfs4/netlogon -UAdministrator -c 'ls'
Enter Administrator password:
Domain=[AD] OS=[Unix] Server=[Samba 4.1.4-SerNet-Debian-7.wheezy]
  .                                   D        O  Thu Feb 20 15:13:27 2014
  ..                                  D        O  Thu Feb 20 15:13:41 2014

Using these keywords you'll find various related issues. Some of them were solved. I tried several without solving the issue or even gaining any more insight. Any ideas how to troubleshoot this situation systematically?

I have a decent experience running samba3 with LDAP and doing Kerberos for PAM in POSIX. But for samba4 and ADS these are my first clumsy steps.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.