Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am currently trying to set up corosync based on this tutorial:

http://www.howtoforge.com/how-to-set-up-an-active-passive-postgresql-cluster-with-pacemaker-corosync-and-drbd-centos-5.5-p3

However, I am not able to get my 2 nodes connected.

I have 2 nodes:

data-master with IP address LAN: 10.0.0.122, Crossover: 172.16.0.1
data-slave with IP address LAN: 10.0.0.123, Crossover: 172.16.0.2

And this is my /etc/corosync/corosync.conf (exactly same as the tutorial):

compatibility: whitetank

totem {
   version: 2
   secauth: off
   threads: 0
   interface {
       ringnumber: 0
       bindnetaddr: 10.0.0.0
       mcastaddr: 226.94.1.1
       mcastport: 4000
   }
}

logging {
   fileline: off
   to_stderr: yes
   to_logfile: yes
   to_syslog: yes
   logfile: /tmp/corosync.log
   debug: off
   timestamp: on
   logger_subsys {
      subsys: AMF
      debug: off
   }
}

amf {
   mode: disabled
}
aisexec {
   user: root
   group: root
}
service {
   # Load the Pacemaker Cluster Resource Manager
   name: pacemaker
   ver: 0
}     

I am able to start the openais service successfully. But, when I checking with crm_mon -1 on both nodes, they have different result:

Node 1 (data-master)

Last updated: Tue Feb 25 19:24:48 2014
Last change: Tue Feb 25 18:49:19 2014 by root via cibadmin on data-master
Stack: classic openais (with plugin)
Current DC: data-master - partition WITHOUT quorum
Version: 1.1.9-2db99f1
2 Nodes configured, 2 expected votes
0 Resources configured.


Online: [ data-master ]
OFFLINE: [ data-slave ]

Node 2 (data-slave)

Last updated: Tue Feb 25 19:25:10 2014
Last change: Tue Feb 25 18:47:17 2014 by root via cibadmin on data-master
Stack: classic openais (with plugin)
Current DC: data-slave - partition WITHOUT quorum
Version: 1.1.9-2db99f1
2 Nodes configured, 2 expected votes
0 Resources configured.


Online: [ data-slave ]
OFFLINE: [ data-master ]

What I expect is to get both nodes online together:

Online: [ data-master data-slave ]

Can you guys help me out what exactly I missed?

My platform: VirtualBox, both Nodes are using SLES 11 SP3 with HA-Extension, both Guest IP Address for LAN is bridged, the Crossover is internal network mode.

Thanks!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

May be you need to switch to unicast from multicast communication.

Try something like this in your corosync.conf:

totem {
        version: 2
        secauth: off
        interface {
                member {
                        memberaddr: 172.16.0.1
                }
                member {
                        memberaddr: 172.16.0.2
                }
                ringnumber: 0
                bindnetaddr: 172.16.0.0
                mcastport: 5405
        }
        transport: udpu
}
share|improve this answer
    
This one's worked! Now crm_mon -1 showing Online: [ data-master data-slave ] ! Thanks! –  mokalovesoulmate Feb 25 at 13:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.