Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to start a Xen HVM guest without VNC, I always get this error

libxl: error: libxl_dm.c:1212:device_model_spawn_outcome: domain 25 device model: spawn failed (rc=-3)
libxl: error: libxl_exec.c:118:libxl_report_child_exitstatus: /etc/xen/scripts/vif-bridge add [7353] exited with error status 1
libxl: error: libxl_create.c:1097:domcreate_attach_pci: unable to add nic devices
libxl: error: libxl_dm.c:1245:libxl__destroy_device_model: Device Model already exited

My config looks like this:

builder         = 'hvm'
memory          = 1024
shadow_memory   = 128

name            = "solaris10.hvm"

vif             = [ 'type=ioemu, bridge=xenbr0' ]
disk            = [ 'phy:/dev/main/solaris10.hvm,hda,w', 'phy:/xen/boot/solaris10.iso,hdb:cdrom,r' ]
boot            = "dc"

vnc            = 0
vnclisten      = '0.0.0.0'

acpi            = 1
apic            = 1
stdvga          = 1
serial          = 'pty'
usbdevice       = 'tablet'

When I set vnc=1, the HVM guest starts without problems.

I already have a freebsd, a netbsd and a windows8 running as HVM, its the same always. I just want to disable VNC for security reasons (having it set to 127.0.0.1 for now until I found a solution).

My Xen version is 4

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.