Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a linux box (called jumper) that is used to access servers in a few separate DMZs. Each DMZ has its own subdomain name (e.g.,, and each subdomain has its own authoritative name server.

We're in the process of replacing the old Solaris jumper with a new Linux box. Most things have worked well, but we have a problem with connecting to servers in the subdomain using SSH. Ping works fine; we can resolv the name using dig, but SSH says "Could not resolve".

Name resolution works well on the server side, and when we connect using the IP address there is no delay or timeout. But SSH on the client side claims to not be able to resolve the server.

Ping and failed SSH connection:

jenny@jumper$  ping
PING ( 56(84) bytes of data.

jenny@jumper$  ssh -v
OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
ssh: Could not resolve hostname Name or service not known

Successful SSH connection using IP instead of host name:

jenny@jumper$  ssh
jenny@'s password: 

The one difference I can see from the client side is that I can't get an authoritative answer from the name servers for idmz, but I do get it from all the other DMZ domains.

share|improve this question
up vote 15 down vote accepted

We contacted the sysadmins for the DNS servers and asked them to verify the setup for idmz. It turned out that their name server claimed to handle IPV6, but it didn't give a correct answer for IPV6 queries.

On the Solaris server, IPV4 was used by default. On the new Linux server, SSH tried IPV6 first. In this case, it meant that since it couldn't resolve the servername using IPV6 it considered it unresolvable. For the other dmz domains, the nameserver gave correct responses even when using IPV6.

We changed the config for SSH to include

AddressFamily inet

and the problem went away.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.