Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I received a PC with not-working usb ports. Strange thing is that when I plug my very basic USB mouse which in other PCs works just fine, the laser flashes (so the voltage is there) but it doesnt work, the cursor is not moving. The PC has windows xp and motherboard Asus M2N-E.

Was thinking that the problem may be driver-related, but I booted the pc from Linux CentOS 6.5 LiveCD and the same situation appeared. Laser was flashing, but the mouse cursor wasnt able to move. The ps/2 mouse works just fine. In BIOS USB and USB2 and USB Legacy are ENABLED.

share|improve this question

closed as off-topic by EEAA, mulaz, Ryan Ries, Michael Hampton Feb 28 at 16:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – EEAA, mulaz, Ryan Ries, Michael Hampton
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This is probably a superuser question, but for sure there's something non functional on that motherboard. –  NickW Feb 28 at 15:00

2 Answers 2

up vote 0 down vote accepted

Do any other USB devices work in XP such as a usb drive?

Can you confirm you have tried all the USB ports?

Have you tried disabling the Legacy USB support?

share|improve this answer
    
All ports are dead, tried also a usb stick in windows - not recognized, disabling legacy support didnt resolve the issue aswell –  user2008937 Feb 28 at 15:21
    
oh! it works, disabling legacy support and reinstalling the USB drivers seems to resolve the problem o_o. thx! –  user2008937 Feb 28 at 15:30

reads like either the USB chip itself (if there is a single one) is damaged somehow or there might be a short cicuit in one of the connectors. Maybe you will be able to see a small crack on the chip and or the lines to your ports.

you might want to check if you can see any dirt or similiar items/small objects short circuit one of the port.

additionally you could debug the usb "hub" which provides these ports, usually called the root hub. for linux you could install and/or mount the usbfs to have debug info, but depending on the time you want to spend for "fixing" this it might be way cheaper to just buy a pci(X) USB card.

share|improve this answer
    
Disabling USB LEGACY SUPPORT in BIOS and resinstalling the drivers seems to resolve the problem. But thanks for you input Dennis! –  user2008937 Feb 28 at 15:34
    
that's a first for me that deactivating actually helps, good to know for further support. –  Dennis Nolte Feb 28 at 15:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.