Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to set up an OpenBSD box to use a LDAP server for authentication. I am following the directions at and for the most part they seem to be working. When I run /usr/libexec/auth/login_-ldap -d -s login USERNAME ldap it authenticates properly, and running ypldap -dv shows output lines like "pushing line:" followed by what looks like a passwd file entry for all my ldap users. So far, so good.

However, when I run getent passwd it still only shows local users (my understanding was that it should show both local and LDAP users), and when I try to authenticate as any LDAP user, authLog shows "Invalid User". What might I have missed?

share|improve this question
up vote 0 down vote accepted

You have to be very careful that the mappings listed in /etc/ypldap.conf are correct for this to work. In this case, the UID parameter was wrong: instead of returning an ID number, it was returning the user name. This does not create an error anywhere, however it does prevent the users from being used.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.