Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a vmdk file and vmx file (and all the other files from someone elses datastore) copied onto my own data store. If I try to deploy from the vmx file, I get a vm with the name "unknown # (invalid)" where # is a sequential number depending on how many times I've tried. If I try to deploy from vmdk, I get an unbootable VM.

Is there an easy way to get a VM up and running from the VM folder?

Edit: When I try to deploy from VMX file, I get this vm:

uknown vm

and I am not able to edit the settings or power it up.

EDIT:

We fixed the issue. The file was given to us from VMPlayer and the hardware version was incompatible. We lowered the HW Version and exported as an .ova file. From there we were able to import into vCenter.

share|improve this question
    
I mean I want to have a usable VM. Someone gave me this VM folder and I want to use it on my host. –  Jeff Mar 4 at 23:26
1  
How are you "deploying" the VM? –  ewwhite Mar 4 at 23:26
    
I copied the 18 GB folder up to the datastore. –  Jeff Mar 4 at 23:30

1 Answer 1

up vote 5 down vote accepted

Are you using the vSphere client? If so, your key is to use the .vmx file.

Generically (without details on versions, etc.), this is accomplished by browsing the datastore, navigating to the VM's folder, right-clicking the relevant .vmx file and Adding the VM to your inventory.

From there, you should have a VM available in your datacenter (or host) inventory. That's when you'd be able to power on the virtual machine.

enter image description here

Edit:

If the .vmx is no good, you can create a NEW virtual machine...

enter image description here

  • Select "Custom".
  • Configure with the requisite specifications.
  • When you get to the "Select a Disk" portion, choose "Use an existing virtual disk".
  • This will open a dialog where you can browse to the .VMDK file.
  • Complete the setup.
  • Profit.
share|improve this answer
1  
And if you do this and you're still getting the VM coming in as "unknown", then there's probably something wrong with the .vmx. It's a text file, open it up and compare with a working one. –  Shane Madden Mar 4 at 23:37
    
Is there a way to generate a new vmx from the vmdk? –  Jeff Mar 4 at 23:49
    
@Jeff See my update above. –  ewwhite Mar 4 at 23:59
    
I tried that too... I will just accept this answer, but I don't know that I asked it correctly. Another note, the zip I was given had a number of snapshots that got reassembled once I fully uploaded the folder. Does that matter? Thanks for your help. –  Jeff Mar 5 at 0:07
    
@Jeff Oh, the snapshots may not have been consolidated. They're not shown in the Datastore Browser dialog on purpose. That could be your problem here. Do you have any access to the original system? –  ewwhite Mar 5 at 0:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.