Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a working TFTP/DHCP PXE boot environment where I've already booted some images successful. Now I built an CentOS 6.5 diskless image and this one is failing booting with the following error:

No filesystem could mount root, tried:  iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

I built the image the following way (followed this excellent tutorial):

dd if=/dev/zero of=new-rootfs.img bs=1M count=512
mkfs.ext4 -F -j new-rootfs.img
<mounted and copied os from template host with rsync to /mnt>
gzip -c new-rootfs.img | dd of=new-rootfs.gz

My PXE line is the following:

    KERNEL vmlinuz0
    APPEND initrd=/images/centos-diskless/rootfs.gz root=/dev/ram0 init=/init noapic acpi=off devfs=nomount raid=noautodetect ramdisk_size=1048576 rw ip=dhcp

One thing which makes me curious is that the kernel is saying tried with iso9660 only and not with ext4 (tried an ext3 image unsuccesful as well). How can I force to try it with ext3/4? Is it a problem with the image?

I would be happy for any help in that case!

share|improve this question
    
Sorry for posting as an aswer but I cant post comments. Did you get any further with your issue. I have the same problem and can't seem to solve it. I used the same tuto – user245683 Sep 29 '14 at 12:53
    
No I didn't got an answer and this is still open. But I used a complete different approach to solve my problem. Sorry for the bad news! – marcap Apr 3 '15 at 16:45

Are You sure that this kernel image has builtin support for anything other then iso9660 ?

You can check for this in the .config file for the kernel image, should be available in /boot/config... or /proc/config.gz (search for CONFIG_EXTX_FS) y is builtin, m is module

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.