Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This morning I tried to install libvirt on one of my servers. The yum install failed with a multilib issue related to the plymouth-core-libs package. Later, when trying a yum update I got a similiar issue but then the packeage with multilib issues was: dbus-libs.

When looking into it a bit more it appears as though yum tries to install 32-bit (i686) versions of these packages for some reason although the 64-bit packages are installed. rpm -qa shows no 32-bit versions of these packages are installed.

Any ideas on what to try next to get yum into a good state (and hopefully prefer 64-bit packages)?

Outputs: Check

# yum check
Loaded plugins: fastestmirror
kernel-2.6.32-431.el6.x86_64 has missing requires of dracut-kernel >= ('0', '002', '18.git413bcf78')
kernel-2.6.32-431.3.1.el6.x86_64 has missing requires of dracut-kernel >= ('0', '002', '18.git413bcf78')
Error: check all

Update

# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.sunet.se
 * extras: ftp.sunet.se
 * rpmforge: mirror.zetup.net
 * updates: ftp.sunet.se
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-431.5.1.el6 will be installed
--> Processing Dependency: dracut-kernel >= 002-18.git413bcf78 for package: kernel-2.6.32-431.5.1.el6.x86_64
--> Running transaction check
---> Package dracut-kernel.noarch 0:004-336.el6_5.2 will be installed
--> Processing Dependency: dracut = 004-336.el6_5.2 for package: dracut-kernel-004-336.el6_5.2.noarch
--> Running transaction check
---> Package dracut.noarch 0:004-336.el6_5.2 will be installed
--> Processing Dependency: plymouth >= 0.8.0-0.2009.29.09.19.1 for package: dracut-004-336.el6_5.2.noarch
--> Running transaction check
---> Package plymouth.x86_64 0:0.8.3-27.el6.centos will be installed
--> Processing Dependency: plymouth-core-libs = 0.8.3-27.el6.centos for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Processing Dependency: system-logos for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Running transaction check
---> Package plymouth-core-libs.i686 0:0.8.3-27.el6.centos will be installed
--> Processing Dependency: librt.so.1(GLIBC_2.2) for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
--> Processing Dependency: librt.so.1 for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
--> Processing Dependency: libm.so.6(GLIBC_2.1) for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
--> Processing Dependency: libm.so.6 for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
--> Processing Dependency: libdl.so.2 for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
--> Processing Dependency: libc.so.6(GLIBC_2.8) for package: plymouth-core-libs-0.8.3-27.el6.centos.i686
---> Package redhat-logos.noarch 0:60.0.14-12.el6.centos will be installed
--> Running transaction check
---> Package glibc.i686 0:2.12-1.132.el6 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.132.el6.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.132.el6.i686
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.14.3-9.el6 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for plymouth-core-libs which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of plymouth-core-libs of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude plymouth-core-libs.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of plymouth-core-libs installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of plymouth-core-libs installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: plymouth-core-libs-0.8.3-27.el6.centos.i686 != plymouth-core-libs-0.8.3-27.0.1.el6.x86_64
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-2.6.32-431.el6.x86_64 has missing requires of dracut-kernel >= ('0', '002', '18.git413bcf78')
kernel-2.6.32-431.3.1.el6.x86_64 has missing requires of dracut-kernel >= ('0', '002', '18.git413bcf78')
share|improve this question

1 Answer 1

up vote 2 down vote accepted

First try yum distro-sync. If you still can't get it synced, use the --skip-broken flag.

share|improve this answer
    
Works perfectly! Any idea what happened or might have caused it? –  Kristofer Mar 7 at 15:01
1  
Look closely at the yum distro-sync output. You will probably notice that at least one package was downgraded. And that is probably because you are using different mirror sites on each run, some of which aren't perfectly in sync with all the rest. –  Michael Hampton Mar 7 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.