Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Server 2008 64-bit on my laptop. I have installed SharePoint (MOSS SP2). Whenever I launch Central Admin, it always opens up in a Firefox browser instead of IE, even though IE is my default browser. Any ideas on how I can change this?

share|improve this question
up vote 7 down vote accepted

Somehow IE can't be the default browser, or at least not completely. When you click on the SharePoint Central Administration link, it executes this command:

"C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\BIN\psconfigui.exe" -cmd showcentraladmin

This starts what is supposed to be the default browser.

Have you tried setting Firefox as the default browser, then closing it and restarting IE to set that as the default browser? Perhaps you need to uninstall Firefox, reset IE as the default browser again, and check the Central Admin shortcut works. Or any combination of these things...

At worse case you may need to choose the Reset button from the Advanced tab of IE (assuming you are running a recent version that has this).

share|improve this answer
Thanks, Alex. Your suggestion to uninstall Firefox was a simple but effective solution and seems to have fixed the problem. Thanks for helping me get around this annoying issue! – Tim Coalson Aug 25 '09 at 11:51

Why have you got FF on a server? I hope you're not browsing the web from it...

Anyway, that aside, how about just popping a shortcut to central admin into your IE favo**u**rites? OK, one extra step, but it'll get you there.

But I really wouldn't do management directly from the server at all. In my environment the only time anyone ever logs on to a server is when they specifically need to do something like installing drivers or Windows Updates. All other work is done remotely if at all possible.

share|improve this answer
Agree but as this is on a laptop I guess it's a demo or lab environment and well, getting another laptop to remotely manage it on the road might be overkill ;) – Oskar Duveborn Aug 24 '09 at 18:17
+1 for 'Why have you got FF on a server? I hope you're not browsing the web from it...' We all need a reminder from time to time. – cop1152 Aug 24 '09 at 18:31
As Oskar suggested, this is a development laptop used for demos and proof of concepts. – Tim Coalson Aug 25 '09 at 11:49

I had the same problem with Opera and IE. After some searching in the registry I found the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open\command After I changed the key to: (Default) = "C:\Program Files (x86)\Internet Explorer\iexplore.exe" "%1" The Central Admin link opened in IE againg.

I'm not really sure what the logic is behind this, but it seems that this key contains the path to the exe-file that must be used to open a http-protocol, where no file extension is present. IE does not seem to overwrite this key when it is set as default, whereas other browsers do overwrite it. This key also has a https-variant.

share|improve this answer

Apparently (and after some searching after seeing the answer above), Firefox writes it's keys into

enter code hereHKEY_CURRENT_USER\Software\Classes\http\

(as \ftp\ and \https\). Removing those keys (and checking the values in HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open\command are correct) solves the problem.

share|improve this answer

Uninstalling Firefox and then Reinstalling allowed me to have both Firefox and a working Central Admin link.

Make sure not to select "Make Default Browser" which is checked by default even in the custom install.

I had this problem and this fix worked for me.

Alex's answer and the comment from OP may be enough, but I was still curious enough to look for more detail beacause I want Firefox for comparison.

I posted the same on Technet:

share|improve this answer

Under certain circumstances, a similar situation can occur when you have installed Chrome, although IE is the default browser. When Chrome is uninstalled, Central Admin is launched in IE. However, unlike with Firefox, when Chrome is installed again Central Admin is again launched in Chrome even though you did not make Chrome the default browser.

The correct steps to resolve this situation are:

  1. Uninstall Chrome.
  2. Run regedit.exe, search for all occurences of Chrome related to Google Chrome and delete them. (Make sure you won't delete any values related to other products, e.g. there's Visual Studio-related key having the word 'chrome' within it.)
  3. Install Chrome again and unchek “Set Google Chrome as my default browser”.

Then Central Admin will keep being launched in the default browser, i.e. in IE.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.