Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up the backup service for a server at work. Specifically, we are using the online backup service SpiderOak. It seems like a fantastic program except for one fact: it uses a graphical interface to do all account setup and management. This isn't a problem in the long run since it runs in the background to do all backups, but right now I'm struggling to get it configured.

My server, of course, doesn't have X or any GUI installed. It seems like a no-brainer to use SSH (with the -X flag for X forwarding) from a GUI-enabled Linux workstation to set it up (in fact this is recommended in the official documentation for the program). The problem here is, it doesn't work.

This is my output:

dan@cobalt:~$ SpiderOak
Fontconfig error: Cannot load default config file
SpiderOak: cannot connect to X server

So, how do I forward X output from my GUIless server to my workstation?

share|improve this question
    
Maybe you should post a snipped of the config file, properly sanitized of course. –  Brad Gilbert Aug 24 '09 at 22:56

2 Answers 2

up vote 4 down vote accepted

By default Ubuntu Server (as of 9.04) does not have xauth installed. You will need to install via apt-get as root or via sudo.

[root@myserver]# apt-get install xauth

In General it's a good idea to verify your SSH settings. On your server check to make sure /etc/sshd_config contains:

X11Forwarding yes

On your client ensure /etc/ssh_config contains:

ForwardX11 yes

To verify if X is forwarding try:

[root@myserver]# xclock

If it works you know that your X is forwarded.

share|improve this answer
    
I doublechecked both of those option and both are set to yes. SpiderOak still returns it's error and xclock returns "Error: Can't open display:" –  DWilliams Aug 24 '09 at 19:43
    
Did you try xclock? Make sure that when you log in, that DISPLAY is set to something like "localhost:10.0" or thereabouts. If xclock fails, then SpiderOak will too. –  Mei Aug 25 '09 at 3:31
    
Installing xauth and restarting the server made it work as expected, thanks! –  DWilliams Aug 25 '09 at 13:47

You need to install a few minimal X11 packages on your server. Not the whole thing, but stuff like xauth and fonts. You didn't mention your distro, but on RedHat/CentOS that would be like xorg-x11-xauth and xorg-x11-fonts-base. Often times, installing 'xterm' will pull in all the necessary dependencies for you. Sorry I don't know the whole list of required packages/files offhand.

Once that's done, on the server, double-check SSH X11 forwarding is working by typing:

echo $DISPLAY

You should see something like "localhost:10.0" if it's working, or a blank line if it's not.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.