Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Samba is working somehow, but some processes crashes. Seams like this is only when some (or one) Windows clients accesses the network disk pushed out by GPO. At least one w7 client can't access the server by the network disks. When the user tries the smb process crashes and the following ocoure in /var/log/samba/log.smbd:

[2014/03/10 14:16:47.897568,  0] lib/fault.c:47(fault_report)
  ===============================================================
[2014/03/10 14:16:47.897702,  0] lib/fault.c:48(fault_report)
  INTERNAL ERROR: Signal 11 in pid 9410 (3.6.17-cdc-4.5.6-302)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2014/03/10 14:16:47.897831,  0] lib/fault.c:50(fault_report)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2014/03/10 14:16:47.897918,  0] lib/fault.c:51(fault_report)
  ===============================================================
[2014/03/10 14:16:47.897978,  0] lib/util.c:1117(smb_panic)
  PANIC (pid 9410): internal error
[2014/03/10 14:16:47.902326,  0] lib/util.c:1221(log_stack_trace)
  BACKTRACE: 21 stack frames:
   #0 /opt/centrify/samba/sbin/smbd(log_stack_trace+0x1c) [0x7fd7f834ee8c]
   #1 /opt/centrify/samba/sbin/smbd(smb_panic+0x2b) [0x7fd7f834ef5b]
   #2 /opt/centrify/samba/sbin/smbd(+0x40af40) [0x7fd7f833ff40]
   #3 /lib/x86_64-linux-gnu/libc.so.6(+0x364a0) [0x7fd7f4d764a0]
   #4 /lib/x86_64-linux-gnu/libc.so.6(cfree+0x1c) [0x7fd7f4dc359c]
   #5 /usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2(+0xcf80) [0x7fd7f2a9cf80]
   #6 /lib64/ld-linux-x86-64.so.2(+0xf90e) [0x7fd7f7d1f90e]
   #7 /lib/x86_64-linux-gnu/libc.so.6(+0x3b901) [0x7fd7f4d7b901]
   #8 /lib/x86_64-linux-gnu/libc.so.6(+0x3b985) [0x7fd7f4d7b985]
   #9 /opt/centrify/samba/sbin/smbd(+0x675a99) [0x7fd7f85aaa99]
   #10 /opt/centrify/samba/sbin/smbd(+0x675bbe) [0x7fd7f85aabbe]
   #11 /opt/centrify/samba/sbin/smbd(+0x18936a) [0x7fd7f80be36a]
   #12 /opt/centrify/samba/sbin/smbd(run_events_poll+0x320) [0x7fd7f835d2a0]
   #13 /opt/centrify/samba/sbin/smbd(smbd_process+0x8ab) [0x7fd7f80bce5b]
   #14 /opt/centrify/samba/sbin/smbd(+0x6740a1) [0x7fd7f85a90a1]
   #15 /opt/centrify/samba/sbin/smbd(run_events_poll+0x320) [0x7fd7f835d2a0]
   #16 /opt/centrify/samba/sbin/smbd(+0x428709) [0x7fd7f835d709]
   #17 /opt/centrify/samba/lib/libtevent.so.0(_tevent_loop_once+0x90) [0x7fd7f5737120]
   #18 /opt/centrify/samba/sbin/smbd(main+0x12df) [0x7fd7f85aa6bf]
   #19 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xed) [0x7fd7f4d6176d]
   #20 /opt/centrify/samba/sbin/smbd(+0x1085c9) [0x7fd7f803d5c9]
[2014/03/10 14:16:47.902958,  0] lib/fault.c:345(dump_core)
  Exiting on internal error (core file administratively disabled)

I have a little suspicion againt DNS, as the windows clients can't access samba through dns name (but the server responds to eg. ping on dns name, and nettatalk works fine for the mac clients with dns. I have changed the gpo to mount network drives from the samba server with IP in stead off dns, and it works fine for most of the clients. I have dismounted all drives on the client which crashes samba, and run gpupdate /force on it.The client gets IP from the AD 2008R2 server, and I have checked that DNS on the client is correct.

Note: Domain name is "opusark.local". I got a warning when installing centrify about the ending "local" is no good at should have been avoided. Can that have something to do about this?

Any clues on how to troubleshoot this error?

OS: Ubuntu 12.04 6 bit Centrify: centrify-samba-4.5.6-deb5-x86_64.tgz Samba version (centrify uses): # /opt/centrify/samba/sbin/smbd --version Version 3.6.17-cdc-4.5.6-302

Logging inn to the server with centrify enabeled ssh is slow, and doesn't work from all computers.

Global in /etc/samba/smb.conf:

[global]
  security = ADS
  realm = OPUSARK.LOCAL
  workgroup = OPUSARK
  netbios name = sinan

  auth methods = guest, sam, winbind, ntdomain
  machine password timeout = 0
  passdb backend = tdbsam:/etc/samba/private/passdb.tdb

  kerberos method = secrets and keytab

  client use spnego principal = true

  send spnego principal = Yes

  server signing = auto

  client ntlmv2 auth = yes
  client use spnego = yes 
  template shell = /bin/bash

  winbind use default domain = Yes

  winbind enum users = No
  winbind enum groups = No
  winbind nested groups = Yes

  idmap cache time = 0

  ignore syssetgroups error = No
  idmap config * : backend  = tdb
  idmap config * : range = 1000 - 200000000
  idmap config * : base_tdb = 0
  enable core files = false
  syslog = 0
share|improve this question

1 Answer 1

up vote 0 down vote accepted

The crash reports have stopped. Probably cause of this was that smbd processes crached when clients was trying to access them by dns name (which for some reason dosn't work).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.