Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Installing 3rd party SSL on DigitalOcean Droplet, Apache running Ubuntu 12.10.

Following the instructions here:

So everything seems to be going all right. I make the edits to all the appropriate files according to the tutorials above, I put in the certificate information I got from AlphaSSL, but when I try to reboot nginx is where I'm hitting a snag.

root@omitted:/etc/nginx/sites-available# sudo service nginx restart
Restarting nginx: nginx: [emerg] SSL_CTX_use_certificate_chain_file("/etc/nginx/cert.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory error:20074002:BIO routines:FILE_CTRL:system lib error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib)
nginx: configuration file /etc/nginx/nginx.conf test failed

Googling this error led me to the following serverfault page, where the fix was to change directory permissions with the following, which I did:

sudo mkdir /etc/nginx/ssl
sudo chown -R root:root /etc/nginx/ssl
sudo chmod -R 600 /etc/nginx/ssl

but I'm still getting the error. I think I'm missing something. Help.

Edit I just realised the cert.pem file does not exist, but I can't seem to figure out why.

Here is /etc/nginx/nginx.conf : (superlong but I didn't know what to leave out...)

user www-data;
worker_processes 4;
pid /var/run/nginx.pid;

events {
    worker_connections 768;
    # multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # nginx-naxsi config
    ##
    # Uncomment it if you installed nginx-naxsi
    ##

    #include /etc/nginx/naxsi_core.rules;

    ##
    # nginx-passenger config
    ##
    # Uncomment it if you installed nginx-passenger
    ##

    #passenger_root /usr;
    #passenger_ruby /usr/bin/ruby;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
#mail {
#       # See sample authentication script at:
#       # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#       # auth_http localhost/auth.php;
#       # pop3_capabilities "TOP" "USER";
#       # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#       server {
#               listen     localhost:110;
#               protocol   pop3;
#               proxy      on;
#       }
#
#       server {
#               listen     localhost:143;
#               protocol   imap;
#               proxy      on;
#       }
#}
share|improve this question
    
Are you sure /etc/nginx/cert.pem is there? –  Fabrizio Mazzoni Mar 11 at 15:37
    
Crickey - you're right it's not there. I'm not sure how to create it either. –  gersande Mar 11 at 17:38
1  
Try and post your nginx.conf so we can see –  Fabrizio Mazzoni Mar 11 at 19:11
    
I just did many thanks!! –  gersande Mar 11 at 21:55

2 Answers 2

According to your error, it seems like nginx can't find /etc/nginx/cert.pem file, I'd suggest you to double check path and permissions (switch to nginx's user and try reading this file).

share|improve this answer

Just check if /etc/nginx/cert.pem is existing. And make sure that certification file is valid. Or you should re-generate a new one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.