Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up a server for a small office. Due to technical difficulties, they had files disappearing constantly. In order to prevent this, I am setting up Apache with Autoversioned Subversion over WebDAV. The server is running Fedora 10 (PPC). I can connect to the server from any Mac in the office, but I get permission errors when I try to save a file. Here is the relevant part of my httpd.conf:

<Directory "/var/yearbook/svn">
    Order allow,deny
    Allow from all
</Directory>

<Location "/">
    DAV svn
    SVNPath /var/yearbook/svn/
    SVNAutoversioning on
    ModMimeUsePathInfo on
</Location>

I can manipulate files from the server, but I get permission errors when I try to save from a Mac. I tried following these instructions, but to no avail. Even when they were enabled, the Mac still created the .DS_Store file. What really bothers me is that it will create a file I told it not to, but refuses to create a file I explicitly save.

A quick look in my error log shows many of these messages:

(2)No such file or directory: Anonymous lock creation is not allowed.  [401, #405]

Everyone needs access to the same things, so I am running the server without authentication. Do you think that this could be the problem?

share|improve this question

3 Answers 3

After further investigation, and some experimentation, I tried adding a username/password requirement to the server. Interestingly, it worked. it's not ideal, as I wanted it to be completely open, but it will work for now. Here's what I added to the httpd.conf:

<Location "/">
    # ...
    AuthType Basic
    AuthName "Yearbook Files"
    AuthUserFile /var/yearbook/yearbook-svn-auth
    Require valid-user
    # ...
</Location>

As a side question, does anyone know how to change the mount point of a WebDAV share on Mac OS X? Currently it shows up in Finder as the server's IP address, and I'd like a friendlier name displayed instead.

share|improve this answer

For your "friendlier names" problem: If you have a local DNS running in the office and all clients configured to default to that domain name (the "Search Domains" preference in MacOS network preferences), clients can just connect to http://server and the share will appear as server in the Finder. Without local DNS, you can do the same with entries in the /etc/hosts file for each client (just add an entry like

192.168.1.10    server

into it).

share|improve this answer
    
Thanks, I hadn't thought about that. I'll try it in the morning to see how well it works. –  Nick Meharry Aug 26 '09 at 5:34
    
+1 Thank you! It shows up correctly now. I found an app that will mount the drives automatically with a username/password combo, so it's totally seamless to the user. –  Nick Meharry Aug 27 '09 at 14:25

You need to set the owner and group of the repository to the user under which apache is running

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.