Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm unable to install GNOME Desktop Environment on FreeBSD-10 w/ pkgng. I'm following FreeBSD's handbook - 6.7. Desktop Environments:

root@:~ # pkg install gnome2
Updating repository catalogue
pkg: No packages matching 'gnome2' available in the repositories
root@:~ # uname -a
FreeBSD  10.0-RELEASE FreeBSD 10.0-RELEASE #0 r260789: Thu Jan 16 22:34:59 UTC 2014     root@snap.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
root@:~ # 

What am I doing wrong? I'm following handbook exactly step-by-step! pkgng itself is working fine, I AM able to install other binary packages (http://pastebin.com/zfvUztUK).


please, do NOT just downvote, use comment section as well to explain what's actually "wrong" (as without your input i cannot improve myself), also if the reason you're down-vote is because I'm not using /usr/ports, well then you need to realize that pkgng is yet another way to get around in FreeBSD.

share|improve this question

closed as off-topic by EEAA, kce, sciurus, Rex, Jenny D Mar 13 at 14:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – EEAA, kce, Rex
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Why don't you build it from the ports tree? Also, why would you want gnome on freebsd? –  Vasili Syrakis Mar 11 at 22:22

1 Answer 1

If you do intend on installing this with the ports tree:

cd /usr/ports/x11/gnome2
make install clean

If you insist on using pkgng you need to enable it using the following instructions if you have not done so:

http://www.freebsd.org/doc/handbook/pkgng-intro.html

You may also need to modify pkgng to point at the freebsd repo

my /usr/local/etc/pkg/repos/FreeBSD.conf:

FreeBSD: {
    url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest"
    Mirror_type: "srv",
    enabled: yes
 }

EDIT: It appears that after updating my pkgng repo catalog the full gnome2 desktop pkg is no longer there. Your other options are to build from the ports tree as is suggested above, build your own pkg, or install gnome2-lite and then install additional packages until you are closer to gnome2 full.

share|improve this answer
    
I am able to use pkgng to install other packages (just not gnome2) see following -> pastebin.com/zfvUztUK –  alexus Mar 12 at 14:15
    
Very strange! I searched gnome2 and found it but needed to update pkgng. I updated pkgng and the pkg list then searched again. Now there is only gnome2-lite. What is the output of pkg search gnome2? –  Chris Jones Mar 12 at 14:39
    
output: pastebin.com/gdA8BdYQ –  alexus Mar 12 at 15:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.