Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install Ioncube on one of my VPSs.Just a little background. This is a CentOS latest, running on an ESXi latest host. The machine has 2GB memory.

I ran php-based loader wizard. I'm trying to install v5.3.

When re-opening the loader, I am presented with this:

Loader Installed
The ionCube Loader version 4.5.3 for PHP 5.3 is already installed and encoded files should run without problems.

Some more information for debugging:

cat /etc/php.d/20-ioncube.ini
zend_extension = /usr/lib64/php/modules/ioncube_loader_lin_5.3.so


php -v
Failed loading /usr/lib64/php/modules/ioncube_loader_lin_5.3.so: /usr/lib64/php/modules/ioncube_loader_lin_5.3.so: undefined symbol: php_body_write
PHP 5.4.25 (cli) (built: Feb 10 2014 08:04:23)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend Guard Loader v3.3, Copyright (c) 1998-2013, by Zend Technologies

ls -lah /usr/lib64/php/modules/
total 19M
drwxr-xr-x. 2 root root  4.0K Mar 12 17:43 .
drwxr-xr-x. 4 root root  4.0K Mar 11 18:57 ..
-rwxr-xr-x. 1 root root   68K Feb 10 08:07 curl.so
-rwxr-xr-x. 1 root root  2.6M Feb 10 08:07 fileinfo.so
-rwxr-xr-x. 1 root root  326K Feb 11 08:07 ioncube_loader_lin_4.1.so
-rwxr-xr-x. 1 root root  324K Feb 11 08:07 ioncube_loader_lin_4.2.so
-rwxr-xr-x. 1 root root  326K Feb 11 08:07 ioncube_loader_lin_4.3.so
-rwxr-xr-x. 1 root root  342K Feb 11 08:07 ioncube_loader_lin_4.3_ts.so
-rwxr-xr-x. 1 root root  328K Feb 11 08:07 ioncube_loader_lin_4.4.so
-rwxr-xr-x. 1 root root  346K Feb 11 08:07 ioncube_loader_lin_4.4_ts.so
-rwxr-xr-x. 1 root root  335K Feb 11 08:07 ioncube_loader_lin_5.0.so
-rwxr-xr-x. 1 root root  347K Feb 11 08:08 ioncube_loader_lin_5.0_ts.so
-rwxr-xr-x. 1 root root  1.1M Feb 11 08:08 ioncube_loader_lin_5.1.so
-rwxr-xr-x. 1 root root  991K Feb 11 08:08 ioncube_loader_lin_5.1_ts.so
-rwxr-xr-x. 1 root root  1.1M Feb 11 08:08 ioncube_loader_lin_5.2.so
-rwxr-xr-x. 1 root root  1.1M Feb 11 08:09 ioncube_loader_lin_5.2_ts.so
-rwxr-xr-x. 1 root root 1018K Feb 11 08:09 ioncube_loader_lin_5.3.so
-rwxr-xr-x. 1 root root  1.1M Feb 11 08:09 ioncube_loader_lin_5.3_ts.so
-rwxr-xr-x. 1 root root  1.2M Feb 11 08:09 ioncube_loader_lin_5.4.so
-rwxr-xr-x. 1 root root  1.2M Feb 11 08:10 ioncube_loader_lin_5.4_ts.so
-rwxr-xr-x. 1 root root  1.2M Feb 11 08:10 ioncube_loader_lin_5.5.so
-rwxr-xr-x. 1 root root  1.2M Feb 11 08:10 ioncube_loader_lin_5.5_ts.so
-rwxr-xr-x. 1 root root   41K Feb 10 08:07 json.so
-rwxr-xr-x. 1 root root  1.3M Feb 10 08:07 mbstring.so
-rwxr-xr-x. 1 root root  137K Feb 10 08:07 mysqli.so
-rwxr-xr-x. 1 root root   53K Feb 10 08:07 mysql.so
-rwxr-xr-x. 1 root root   33K Feb 10 08:07 pdo_mysql.so
-rwxr-xr-x. 1 root root  100K Feb 10 08:07 pdo.so
-rwxr-xr-x. 1 root root   26K Feb 10 08:07 pdo_sqlite.so
-rwxr-xr-x. 1 root root  259K Feb 10 08:07 phar.so
-rwxr-xr-x. 1 root root   45K Feb 10 08:07 sqlite3.so
-rwxr-xr-x. 1 root root  1.1M Jun 14  2013 ZendGuardLoader.so
-rwxr-xr-x. 1 root root   93K Feb 10 08:07 zip.so

Please advise if you need any additional information. Thank you.

share|improve this question
    
You're loading ioncube for 5.3 and you're running 5.4. Edit the .ini to point to the right one. –  Nathan C Mar 12 at 14:46
    
Thank you! Can you put that as an answer? –  Zack Magee Mar 12 at 14:54

1 Answer 1

up vote 1 down vote accepted

From the looks of it, you're loading ioncube for PHP 5.3, and you're using PHP 5.4.

Adjust the ini file to use 5.4 and you'll be good to go.

share|improve this answer
    
Yes! Thank you :) –  Zack Magee Mar 12 at 15:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.