Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install a stable latest version of couchdb on a Debian 7 server. Sadly for me the packages on the Debian repository are old (1.2) and i need 1.4 and up I've decided to try and use the ppa (ppa:couchdb/stable) to install it with apt-get. I successfully added the ppa as a repository but i get this error while installing it like so:

sudo apt-get install -V couchdb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 couchdb : Dependes: couchdb-bin (>= 1.5.0-0ubuntu2) but it is not going to be in
stalled
E: Unable to correct problems, you have held broken packages.

I understands that it probably can't find the required dependencies with the required minimum version but do i have to add each dependency's ppa separately or is there an easier way to do this?

Thanks in advance, Itay

share|improve this question
    
You seem to be trying to install Ubuntu packages on Debian. Don't do this. It is not guaranteed to work. –  Michael Hampton Mar 12 at 21:43
    
I do realise this and yet i've decided to try. –  itaywss Mar 12 at 21:48
2  
Your trial is at an end, then. –  Michael Hampton Mar 12 at 21:52
    
You would be better off trying to backport the sid release... –  Zoredache Mar 12 at 21:57
    
Ok ok you've convinced me, Hope you're all very pleased with yourselves... –  itaywss Mar 12 at 22:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.