Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm working on setting up host auto-discovery for Nagios using DNS records.

When I try to use dig axfr to do a zone transfer (dig axfr local.domain.com), however, I get the following output:

[jwestbury@nagiosv local]# dig AXFR local.domain.com

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.6 <<>> AXFR local.domain.com
;; global options: +cmd
; Transfer failed.

The DNS server I'm querying is not showing anything in its logs for this query. If I change the domain to a non-existent one, I do see an entry in the DNS Server logs in Event Viewer, so I know the queries are hitting the DNS server fine.

Is there something special I need to do in order to allow AXFR transfers from the Nagios machine? Or is there somewhere else I should be looking for logs on the Nagios machine to indicate what might have happened when I tried to perform the transfer?

Any help would be appreciated. Thanks.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You need to enable and allow Zone Transfers for the zone you want to transfer. You can configure this on the Zone Transfers tab of the zone's properties pages.

share|improve this answer
    
Perfect, thanks! I couldn't find where to allow the zone transfers -- thanks for pointing me to it! –  James Westbury Mar 13 '14 at 21:42
    
Glad to help... –  joeqwerty Mar 13 '14 at 21:55
    
Just an extra note for anyone who finds this in the future: For some reason, the context menu for the zone will have properties greyed out and unselectable sometimes. I solved this by just toggling my selection back and forth on the left-hand menu, then right-clicking the zone again. Not sure why it works like that, but, eh, it does. –  James Westbury Mar 13 '14 at 22:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.