Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

After upgrading dovecot from 1.2 to 2.1.7 (while upgrading squeeze to wheezy) sieve no longer does it's job. (And breaks mail delivery)

apt-purging all dovecot packages and reinstalling did not improve the situation, i still get the same error message:

==> mail.err <==
Mar 14 13:40:14 xxx dovecot: deliver(postmaster@xxx.de): dlopen(/usr/lib/dovecot/modules//lib90_sieve_plugin.so) failed: /usr/lib/dovecot/libdovecot-sieve.so.0: undefined symbol: i_debug
Mar 14 13:40:14 xxx dovecot: deliver(postmaster@xxx.de): Fatal: Couldn't load required plugins

==> mail.info <==
Mar 14 13:40:14 xxx postfix/pipe[15828]: 13B1F19E0792: to=<xxx@xxx.de>, orig_to=<xxx@xxx.de>, relay=dovecot, delay=0.43, delays=0.32/0.01/0/0.09, dsn=4.3.0, status=deferred (temporary failure)

dovecot.conf:

protocols = imap lmtp sieve

mail_plugin_dir = /usr/lib/dovecot/modules/

[snip]
...
[/snip]

protocol lda {
  mail_plugins = $mail_plugins sieve
  #mail_plugins = sieve
}

protocol lmtp {
  mail_plugins = $mail_plugins sieve
}


plugin {
  #recipient_delimiter = +
  sieve = ~/.dovecot.sieve
  sieve_dir = ~/sieve
}

ll /usr/lib/dovecot/libdovecot-siev*

lrwxrwxrwx 1 root root      25 Feb  5  2013 libdovecot-sieve.so -> libdovecot-sieve.so.0.0.0
lrwxrwxrwx 1 root root      25 Feb  5  2013 libdovecot-sieve.so.0 -> libdovecot-sieve.so.0.0.0
-rw-r--r-- 1 root root  540304 Feb  5  2013 libdovecot-sieve.so.0.0.0

ll /usr/lib/dovecot/modules/*sieve*

-rw-r--r-- 1 root root 18392 Feb  5  2013 /usr/lib/dovecot/modules/lib90_sieve_plugin.so
share|improve this question

1 Answer 1

up vote 0 down vote accepted

problem solved:

in postfix mails were piped to dovecot's deliver istead of lmtp

deleting the pipe in /etc/postfix/master.cf,

dovecot   unix  -       n       n       -       -       pipe
 flags=DORhu user=nobody argv=/usr/local/lib/dovecot/deliver -f ${sender}
 -d ${user}@${nexthop} -n -m ${extension}

and adding a virtual trasport to /etc/postfix/main.cf,

virtual_transport = lmtp:unix:private/dovecot-lmtp

or

virtual_transport = lmtp:unix:/var/run/dovecot/lmtp

fixed the issue for me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.