Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a QNAP NAS on my network that exports some NFS shares, which I'm mounting on a linux machine. One of the shares has data only (no executable files). However, when I mount the NFS share, all the files show up as -rwxrwxrwx (777).

I have the share mounted with noexec, but I was wondering if there was a way to mount the share such that the files would appear as if their mode was -rw-r--r-- (644)?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

My understanding is that NFS works off of whatever file system permissions are set on the server's file system. You should be able modify these by issuing a chmod on either the client, or the server (although I don't know if you have access to the command line on the QNAP device).

With regards to the noexec option, that simply prohibits executable files from being ran on that file system... it doesn't prevent you from setting the execute bit in the files permissions.

Hope this helps!

share|improve this answer
    
Did this help Marc, or was there something I missed? If I missed something let me know and I'd be happy to try and answer this. –  mdadm Mar 17 at 22:46
    
Sorry for not replying before, was really busy :) Yes, that's correct. Turns out that I'm sync'ing the files from a Mac to the NAS (via an AFP mount), and that the permissions get screwed up at that point. I should probably ask another question for that part of the problem. Thanks! –  Marc-Antoine Mar 19 at 20:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.