Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have opened 2 threads at Microsoft's places already:

http://social.technet.microsoft.com/Forums/windowsserver/en-US/f3cfdba6-5b3e-4342-85ef-fd68fb59fef4/enable-fxp-in-server-2012-r2-iis-80-?forum=winserver8gen#a0a5ad52-71e7-4e27-847e-5c810d9d2040

http://forums.iis.net/t/1208163.aspx?IIS+8+0+Enable+FXP+in+IIS+FTP+

But no one seems to be able to help me, or know the answer. As I have mentioned I read the 7.5 documentation but I can't find any options within IIS 8.5.

PASV port range is enabled and the FTP does work. If I try to FXP I get:

(17:40:23) [2] 501-Server cannot accept argument.
(17:40:23) [2]  Win32 error:   The parameter is incorrect. 
(17:40:23) [2]  Error details: Client IP on the control channel didn't match the client IP on the data channel.
(17:40:23) [2] 501 End

which of course is expected since I haven't enabled FXP

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It seems you are looking for the dataChannelSecurity element under system.ftpServer/security node.

On my IIS 8.5, the settings are under system.applicationHost/sites/siteDefaults/ftpServer/security/dataChannelSecurity,

so you were looking in the wrong place, the location is the same for IIS 7.5

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.