Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

OS: FreeBSD9 64 Bit

MTA: Exim with SA-Exim, Auth-Radius, Content Scan options

I use exim -v user with default install (without even tweaking anything)

LOG: MAIN PANIC
failed to read delivery status for user@localhost.domain.tld from delivery subprocess.
LOG: MAIN PANIC
appendfile transport process returned non zero status 0x0100 exit code 1

Can you tell Why exim is not reading from delivery subprocess. Is some other process is blocking it ???

ps gives

633      v0      ls      0:00:01      login [pam] (login)
641      v0      S       0:00:01      -csh (csh)
662      v0      R+      0:00:00      PS
share|improve this question

1 Answer 1

up vote 1 down vote accepted

sounds like the appendfile driver can't write to the destination mailbox file.

Did you check for permission issues?

Who owns the destination file and containing directories?

Who owns the exim4 binary?

Does it have/needs the sticky bit to be set?

share|improve this answer
    
thank you @alxgomz, there was no read/write permissions on destination, thanks a lot but will I need to adjust permission for each user (existing/new) in order to trouble shoot this problem. –  Nishan Mar 16 at 11:19
    
but @alxgomz will I need to adjust permission for each user (existing/new) in order to trouble shoot this problem. –  Nishan Mar 16 at 11:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.