Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some reason, apt-get upgrade isn't working today. This is what I see when I try to upgrade :

root@localhost:~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  chromium-browser chromium-browser-l10n chromium-codecs-ffmpeg gir1.2-gtk-3.0 libgail-3-0 libgtk-3-0 libgtk-3-bin libgtk-3-common librsvg2-2 librsvg2-common oracle-java7-installer tzdata update-manager
  update-manager-core
14 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,117 kB/47.5 MB of archives.
After this operation, 5,877 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  oracle-java7-installer tzdata update-manager-core update-manager
Install these packages without verification [y/N]? y
Get:1 http://security.ubuntu.com/ubuntu/ precise-security/main libgtk-3-common all 3.4.2-0ubuntu0.7 [145 kB]
Err http://security.ubuntu.com/ubuntu/ precise-security/main librsvg2-common amd64 2.36.1-0ubuntu1.1
  403  AuthorizedOnly [IP: 91.189.88.149 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main librsvg2-2 amd64 2.36.1-0ubuntu1.1
  403  AuthorizedOnly [IP: 91.189.88.149 80]
Err http://security.ubuntu.com/ubuntu/ precise-security/main gir1.2-gtk-3.0 amd64 3.4.2-0ubuntu0.7
  403  AuthorizedOnly [IP: 91.189.88.149 80]
Get:2 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main update-manager all 1:0.156.14.12 [611 kB]
Fetched 756 kB in 2s (358 kB/s)         
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/libr/librsvg/librsvg2-common_2.36.1-0ubuntu1.1_amd64.deb  403  AuthorizedOnly [IP: 91.189.88.149 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/libr/librsvg/librsvg2-2_2.36.1-0ubuntu1.1_amd64.deb  403  AuthorizedOnly [IP: 91.189.88.149 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/g/gtk+3.0/gir1.2-gtk-3.0_3.4.2-0ubuntu0.7_amd64.deb  403  AuthorizedOnly [IP: 91.189.88.149 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Any idea what went wrong or how to fix it?

Thanks for taking a look!

share|improve this question
1  
Have you tried apt-get update before the upgrade ? –  krisFR Mar 18 at 18:40
    
Okay, looks like I should have just followed directions to begin with. I ran : apt-get upgrade --fix-missing . It executed without issue. I rand apt-get upgrade a couple more times until there was nothing left to update. However, when I run apt-get update, I still get 403 "Failed to fetch" errors when trying to contact us.archive.ubuntu.com/ubuntu/dists/precise-backports . Any idea what's going on here? –  sangfroid Mar 18 at 18:50
    
What happens if you manually try to grab one of those packages? Are you behind any sort of weird firewall or similar? –  devicenull Mar 19 at 2:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.