Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using cheap VDS hosting. So have a hard RAM limit. (256 Mb) I was trying to switch from apache to a new web server cherokee. So turned off apache, and configured cherokee to work instead. But then the server was rebooted and apache automatically started (as cherokee did).

So now I have 2 servers which listen to 80 port. And no one works

Also I think that all RAM was consumed...

ssh doesn't work:

silver:~ oleg$ ssh root@oplot.vds.colocall.com 
ssh_exchange_identification: Connection closed by remote host
silver:~ oleg$ 

And when I call their sys admins they say me call your system administrator.

What should I do in this situation?

silver:~ oleg$ ssh -vvv root@oplot.vds.colocall.com OpenSSH_5.1p1, OpenSSL 0.9.7l 28 Sep 2006 debug1: Reading configuration data /Users/oleg/.ssh/config debug1: Applying options for oplot.vds.colocall.com debug1: Reading configuration data /etc/ssh_config debug2: ssh_connect: needpriv 0 debug1: Connecting to oplot.vds.colocall.com [62.149.25.66] port 22. debug1: Connection established. debug1: identity file /Users/oleg/.ssh/identity type -1 debug3: Not a RSA1 key file /Users/oleg/.ssh/id_rsa. debug2: key_type_from_name: unknown key type '-----BEGIN' debug3: key_read: missing keytype debug2: key_type_from_name: unknown key type 'Proc-Type:' debug3: key_read: missing keytype debug2: key_type_from_name: unknown key type 'DEK-Info:' debug3: key_read: missing keytype debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug3: key_read: missing whitespace debug2: key_type_from_name: unknown key type '-----END' debug3: key_read: missing keytype debug1: identity file /Users/oleg/.ssh/id_rsa type 1 debug1: identity file /Users/oleg/.ssh/id_dsa type -1 ssh_exchange_identification: Connection closed by remote host silver:~ oleg$

share|improve this question
    
First off, use the -v flags to ssh to check exactly what the problem is. ssh -vvv will give you many, many debugging messages which should tell you why you can't log in. –  CK. Aug 25 '09 at 9:05
    
Just added comment with output –  oleg Aug 25 '09 at 9:16
add comment

3 Answers

Looks to me like it's your ssh client that's the issue. From my box:

$ ssh foo@oplot.vds.colocall.com
foo@oplot.vds.colocall.com's password:

Are you trying from your usual box? Do you have a different box you can try from?

share|improve this answer
add comment

Well, apache is listening on port 80, presumably because it was started first. You can disable apache by running chkconfig --level 345 httpd off.

The behaviour of the server is consistent with hitting an enforced memory limit, as you wouldn't be able to fork any new processes. If this is the case, and you only have ssh access, then there's probably nothing you can do without some intervention by the VPS provider.

share|improve this answer
add comment

can you get remote console access to the virtual machine?

if so, you could reboot it into single-user mode (or just reboot with init=/bin/bash and remount the root fs as RW), change the config so that only one of apache or cherokee is going to start up, and then reboot again.

failing that, as theotherreceive suggested, maybe someone at your VPS provider can do that for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.