Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I compiled OpenSSH_6.6p1 on one of our server. I am able login via SSH to the upgraded server. But I am not able to connect to other servers running OpenSSH_6.6p1 or OpenSSH_5.8 from this. While connecting I am getting an error as below.

Read from socket failed: Connection reset by peer

On the destination server in the logs, I am seeing it as below.

sshd: fatal: Read from socket failed: Connection reset by peer [preauth]

I tried specifying the cipher_spec [ ssh -c aes128-ctr destination-server ] as mentioned in here and was able to connect. How can configure ssh to use the cipher by default? Why is the cipher required here?

share|improve this question
    
From the server from which you get this error, what happens when you do telnet ip.or.name.of.offending.server 22? –  MadHatter Mar 24 at 12:39
    
Both sides seem to think the other side closed the connection. At this point I would break out tcpdump or wireshark and run it on both ends. –  Michael Hampton Mar 24 at 12:41
    
@MadHatter I am able to telnet on port 22 and get SSH response. –  nitins Mar 25 at 6:13
    
OK, thanks nitins, just checking the basics. –  MadHatter Mar 25 at 7:27
    
Try compiling previous versions of openssh like 6.5p1 to see if this behaviour is due to a change in codebase? –  coincoin Mar 25 at 10:08

3 Answers 3

up vote 3 down vote accepted
+50

The problem sounds like a server-side bug. When the client sends the list of ciphers the openssh server probably expects to be able to read the list in a single system call.

If the list of supported ciphers is longer than can be transmitted in one packet, the server may get fewer bytes in the first call than it expected. The correct behavior on the server would be to perform another call to get the rest of the bytes. But from the problem description it appears, the server instead closes the connection when it did not get the full list of ciphers at once. When the next packet from the client arrives, the server will send a connection reset to the client.

Configuring the client to use a shorter list of ciphers would then work around the bug. The openssh client will look for the list of ciphers in the following places:

  1. On the command line using either -c cipher_spec or -o Ciphers=cipher_spec
  2. In ~/.ssh/config by specifying Ciphers cipher_spec in the relevant host section or before the first host.
  3. In /etc/ssh/ssh_config using the same format as ~/.ssh/config
  4. A default list built into the client at compile time.

The two configuration files are respectively per-user and system-wide settings. Using Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc like Eric suggested should work fine.

share|improve this answer

You can specify cipher in ssh config file (/etc/ssh/ssh_config or similar, depends on $PREFIX etc). Any option you pass to ssh client on command line can be set in ssh (client) config file.

Here is the relevant line (just uncomment):

#   Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
share|improve this answer

My problem that had the exact same symptoms you are seeing was due to truncated host keys. Try recreating them with:

sudo rm /etc/ssh/ssh_host_*
sudo ssh-keygen -A
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.