Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My website can be reached at www.fonix-energia.hu and fonix-energia.hu. In the first case, the website appears to be fallen apart, while without the www it works perfectly. There is only one single copy of the site in the /var/www/fonix folder, there should be no alternate versions on the server at all.

Here is my DNS configuration, the two addresses should point to the same place:

Name                           TTL    Class   Type    Record  
fonix-energia.hu.              14400  IN  A     95.85.47.115  
localhost.fonix-energia.hu.    14400  IN  A     127.0.0.1 
mail.fonix-energia.hu.         14400  IN  CNAME ghs.googlehosted.com  
ftp.fonix-energia.hu.          14400  IN  A     195.56.100.77 
cpanel.fonix-energia.hu.       14400  IN  A     195.56.100.77 
webdisk.fonix-energia.hu.      14400  IN  A     195.56.100.77 
whm.fonix-energia.hu.          14400  IN  A     195.56.100.77 
webmail.fonix-energia.hu.      14400  IN  A     195.56.100.77 
autoconfig.fonix-energia.hu.   14400  IN  A     195.56.100.77 
autodiscover.fonix-energia.hu. 14400  IN  A     195.56.100.77 
fonix-energia.hu.              14400  IN  TXT   google-site-verification=[CENSORED]

www.fonix-energia.hu.          14400  IN  CNAME fonix-energia.hu

Here is the apache2 config, here I thought the virtualhost configuration also points to the same location:

<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin info@fonix-energia.hu
    DocumentRoot /var/www



    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot /var/www/fonix
    ServerName fonix-energia.hu
    # Other directives here
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot /var/www/fonix
    ServerName www.fonix-energia.hu
    # Other directives here
</VirtualHost>

Any help would be much appreciated.

share|improve this question
4  
Can you define fallen apart, I had a look and it looks okay. Plus if your using two virtual hosts to host the same site just under the two root and the www domains then you should really use ServerAlias and just have the one virtual host. –  Shutupsquare Mar 20 at 21:10
1  
You may have some javascript code running on your site that depends on the www in the url. Bad developers will always be around :) –  Andrei Dvoynos Mar 20 at 21:55
    
Thanks for the virualhost remarks, however, that did not seem to solve the problem. The site looks like this from multiple browsers: fonix-energia.hu/DL/default.png fonix-energia.hu/DL/fallen.png The slider changed between the two screenshots, but never mind that. I also checked it from a colleague's computer with different screen size and resolution and the www version is not broken apart. Also I didn't find any javascript depending on the www. –  user213490 Mar 21 at 10:33
    
Now I noticed that he viewed it with Google Chrome when it worked. –  user213490 Mar 21 at 10:41

2 Answers 2

Take out the second VirtualHost, it should be just one with www. as an alias:

<VirtualHost *:80>
    DocumentRoot /var/www/fonix
    ServerName fonix-energia.hu
    ServerAlias www.fonix-energia.hu
    # Other directives here
</VirtualHost>
share|improve this answer

Although its not the cause of your problem just an FYI, you don't need to be using a CNAME for the www instead use an A record just like you did for fonix-energia.hu. Another nitpick of mine is you don't have to use FQDN in your records.

So instead of:

fonix-energia.hu.              14400  IN  A     95.85.47.115

You can use:

@              14400  IN  A     95.85.47.115

Instead of the CNAME:

www.fonix-energia.hu.          14400  IN  CNAME fonix-energia.hu

You can use:

www              14400  IN  A     95.85.47.115

Or:

www.fonix-energia.hu.              14400  IN  A     95.85.47.115
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.