Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install AppFabric 1.1 on 64bit Windows Server 2012 R2.

  • All updates have been installed and updates are turned ON
  • .NET Framework 4.0 is installed
  • .NET Framework 3.5 is installed
  • IIS is installed
  • Windows Powershell 3.0 should already be included in Server 2012

I am getting the following error:

2014-03-21 11:02:34, Information           Setup  ===== Logging started: 2014-03-21 11:02:34+01:00 =====
2014-03-21 11:02:34, Information           Setup  File:             c:\6c4006b0b3f6dee1bf616f1967\setup.exe
2014-03-21 11:02:34, Information           Setup  InternalName:     Setup.exe
2014-03-21 11:02:34, Information           Setup  OriginalFilename: Setup.exe
2014-03-21 11:02:34, Information           Setup  FileVersion:      1.1.2106.32
2014-03-21 11:02:34, Information           Setup  FileDescription:  Setup.exe
2014-03-21 11:02:34, Information           Setup  Product:          Microsoft(R) Windows(R) Server AppFabric
2014-03-21 11:02:34, Information           Setup  ProductVersion:   1.1.2106.32
2014-03-21 11:02:34, Information           Setup  Debug:            False
2014-03-21 11:02:34, Information           Setup  Patched:          False
2014-03-21 11:02:34, Information           Setup  PreRelease:       False
2014-03-21 11:02:34, Information           Setup  PrivateBuild:     False
2014-03-21 11:02:34, Information           Setup  SpecialBuild:     False
2014-03-21 11:02:34, Information           Setup  Language:         Language Neutral
2014-03-21 11:02:34, Information           Setup  
2014-03-21 11:02:34, Information           Setup  OS Name:                   Windows Server 2012 R2 Standard
2014-03-21 11:02:34, Information           Setup  OS Edition:                ServerStandard
2014-03-21 11:02:34, Information           Setup  OSVersion:                 Microsoft Windows NT 6.2.9200.0
2014-03-21 11:02:34, Information           Setup  CurrentCulture:            sl-SI
2014-03-21 11:02:34, Information           Setup  Processor Architecture:    AMD64
2014-03-21 11:02:34, Information           Setup  Event Registration Source :    AppFabric_Setup
2014-03-21 11:02:34, Information           Setup  
2014-03-21 11:02:34, Information           Setup  Microsoft.ApplicationServer.Setup.Upgrade.V1UpgradeSetupModule : Initiating V1.0 Upgrade module.
2014-03-21 11:02:34, Information           Setup  Microsoft.ApplicationServer.Setup.Upgrade.V1UpgradeSetupModule : V1.0 is not installed.
2014-03-21 11:02:54, Information           Setup  Microsoft.ApplicationServer.Setup.Upgrade.V1UpgradeSetupModule : Initiating V1 Upgrade pre-install.
2014-03-21 11:02:54, Information           Setup  Microsoft.ApplicationServer.Setup.Upgrade.V1UpgradeSetupModule : V1.0 is not installed, not taking backup.
2014-03-21 11:02:55, Information           Setup  Executing C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe with commandline -iru.
2014-03-21 11:02:55, Information           Setup  Return code from aspnet_regiis.exe is 0
2014-03-21 11:02:55, Information           Setup  Process.Start: C:\Windows\system32\msiexec.exe /quiet /norestart /i "c:\6c4006b0b3f6dee1bf616f1967\Microsoft CCR and DSS Runtime 2008 R3.msi" /l*vx "C:\Users\Administrator\AppData\Local\Temp\AppServerSetup1_1(2014-03-21 11-02-55).log"
2014-03-21 11:02:57, Information           Setup  Process.ExitCode: 0x00000000
2014-03-21 11:02:57, Information           Setup  Windows features successfully enabled.
2014-03-21 11:02:57, Information           Setup  Process.Start: C:\Windows\system32\msiexec.exe /quiet /norestart /i "c:\6c4006b0b3f6dee1bf616f1967\Packages\AppFabric-1.1-for-Windows-Server-64.msi" ADDDEFAULT=Worker,WorkerAdmin,CacheService,CacheAdmin,Setup /l*vx "C:\Users\Administrator\AppData\Local\Temp\AppServerSetup1_1(2014-03-21 11-02-57).log" LOGFILE="C:\Users\Administrator\AppData\Local\Temp\AppServerSetup1_1_CustomActions(2014-03-21 11-02-57).log" INSTALLDIR="C:\Program Files\AppFabric 1.1 for Windows Server" LANGID=en-US
2014-03-21 11:03:45, Information           Setup  Process.ExitCode: 0x00000643
2014-03-21 11:03:45, Error                 Setup  AppFabric installation failed because installer MSI returned with error code : 1603
2014-03-21 11:03:45, Error                 Setup  
2014-03-21 11:03:45, Error                 Setup  AppFabric installation failed because installer MSI returned with error code : 1603
2014-03-21 11:03:45, Error                 Setup  
2014-03-21 11:03:45, Information           Setup  Microsoft.ApplicationServer.Setup.Core.SetupException: AppFabric installation failed because installer MSI returned with error code : 1603
2014-03-21 11:03:45, Information           Setup     at Microsoft.ApplicationServer.Setup.Installer.WindowsInstallerProxy.GenerateAndThrowSetupException(Int32 exitCode, LogEventSource logEventSource)
2014-03-21 11:03:45, Information           Setup     at Microsoft.ApplicationServer.Setup.Installer.WindowsInstallerProxy.Invoke(LogEventSource logEventSource, InstallMode installMode, String packageIdentity, List`1 updateList, List`1 customArguments)
2014-03-21 11:03:45, Information           Setup     at Microsoft.ApplicationServer.Setup.Installer.MsiInstaller.InstallSelectedFeatures()
2014-03-21 11:03:45, Information           Setup     at Microsoft.ApplicationServer.Setup.Installer.MsiInstaller.Install()
2014-03-21 11:03:45, Information           Setup     at Microsoft.ApplicationServer.Setup.Client.ProgressPage.StartAction()
2014-03-21 11:03:45, Information           Setup  
2014-03-21 11:03:45, Information           Setup  === Summary of Actions ===
2014-03-21 11:03:45, Information           Setup  Required Windows components   :  Completed Successfully
2014-03-21 11:03:45, Information           Setup  IIS Management Console            :  Completed Successfully
2014-03-21 11:03:45, Information           Setup  Microsoft CCR and DSS Runtime 2008 R3         :  Completed Successfully
2014-03-21 11:03:45, Information           Setup  AppFabric 1.1 for Windows Server  :  Failed
2014-03-21 11:03:45, Information           Setup  Hosting Services          :  Failed
2014-03-21 11:03:45, Information           Setup  Caching Services          :  Failed
2014-03-21 11:03:45, Information           Setup  Hosting Administration            :  Failed
2014-03-21 11:03:45, Information           Setup  Cache Administration          :  Failed
2014-03-21 11:03:45, Information           Setup  Microsoft Update  :  Skipped
2014-03-21 11:03:45, Information           Setup  Microsoft Update          :  Skipped
2014-03-21 11:03:45, Information           Setup  
2014-03-21 11:03:45, Information           Setup  ===== Logging stopped: 2014-03-21 11:03:45+01:00 =====

I have tried this solution but no success: http://stackoverflow.com/questions/11205927/appfabric-installation-failed-because-installer-msi-returned-with-error-code-1

My system enviroment variable PSModulesPath has this value: C:\Windows\System32\WindowsPowerShell\v1.0\Modules

I have also followed this link with no success: http://jefferytay.wordpress.com/2013/12/11/installing-appfabric-on-windows-server-2012/

Any help would be greatly appreciated !

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Resolution:

Deleted the groups AS_Observers and AS_Administrators (if they are there), and then installation succeeded.

Good day.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.