Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Have a DELL Poweredge T110 ii with a S100 embedded controller and I just replaced a failed disk. Its a simple mirrored pair and when I assigned the new disk as a Global Spare the rebuilding starts. There is also 2 Virtual Disks on these disks and virtual disk 1 recovers with a state of ready but virtual disk 2 has a state of failed.

Anyone got any ideas why this would happen?

Thanks,

John

share|improve this question
    
Are both virtual disks the same RAID level, or was VD2 RAID0? –  MDMarra Mar 22 at 15:05
    
Hi there both the same. Raid 1 –  John Mar 22 at 16:34

1 Answer 1

I would try removing the drive and rebooting, then shutting down to re-insert it again - force both virtual disk rebuilds to start again.

Alternatively, you may also want to double-check that you're running up-to-date driver and firmware versions for that controller too.

If this doesn't seem to work, it could be that the rebuild is failing partway through the 2nd virtual disk due to a bad block on the source drive... at that point, you may be stuck with backing up data and reimaging/restoring to give things a fresh start.

share|improve this answer
    
Thanks for the comments - I think it's going to end up being a bad block on the scource drive. Going to scan the drive now to confirm. Other wise i'll try your first suggestion. I've checked the drivers and firmware there all up to date. Thanks! –  John Mar 26 at 9:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.