Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I had installed apache webserver on my local machine (Linux Mint 15) and everything was working fine until I tried to install npm/nodejs.

I'm getting this error whenever I try starting apache -

module.js:340
throw err;
      ^
Error: Cannot find module '/LANG=en_US.UTF-8'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:901:3

I have scoured the internet to find solution to this problem and make apache work again, but in vain.

My problem is thus - I don't need nodejs. I have removed and uninstalled npm and node using apt-get. I have manually removed all the node_modules and node directories from /usr/lib and ~. But the problem still remains.

I checked every .conf and .load file for apache and still cannot figure out where/how/why apache is loading module.js and node.js files from.

Can someone help with this?

EDIT:

Contents of my mods-enabled folder:

access_compat.load  authz_user.load  filter.load       php5.load
alias.conf          autoindex.conf   mime.conf         setenvif.conf
alias.load          autoindex.load   mime.load         setenvif.load
auth_basic.load     deflate.conf     mpm_prefork.conf  status.conf
authn_core.load     deflate.load     mpm_prefork.load  status.load
authn_file.load     dir.conf         negotiation.conf
authz_core.load     dir.load         negotiation.load
authz_host.load     env.load         php5.conf
share|improve this question
    
Check ls /etc/apache2/mods-enabled/ if it's there do a2dismod module to disable and restart apache –  LinuxDevOps Mar 22 at 17:30
    
Updated the question with the contents of the mods-enabled folder. Don't think it's here. –  Sterex Mar 22 at 17:35
    
Check for any reference to module.js , node.js in apache configuration: find /etc/apache2/ |xargs grep 'js' –  LinuxDevOps Mar 22 at 17:38
    
@LinuxDevOps Nope. No references to any JS files in there. :\ –  Sterex Mar 22 at 17:46
    
Check if node is running already ps -auxf|grep node or netstat -tlpn –  LinuxDevOps Mar 22 at 22:43

1 Answer 1

up vote 0 down vote accepted

Ok, I finally got to the bottom of this!

Firstly, the problem (I suspect) was a corrupted /usr/bin/env file which was edited (perhaps by npm/nodejs installation) to load many (many, many) other files by additional shell script that looked node-related.

Secondly, mpm_prefork of apache2 installation was also corrupted - this is possibly my fault trying to find/fix the above error, I may have done something!

The solution was to reinstall everything -

sudo apt-get install --reinstall coreutils -- To fix the /usr/bin/env file.

sudo apt-get purge apache2 apache2-utils apache2.2-bin

sudo apt-get autoremove -- To uninstall and cleanup existing apache2 install

sudo apt-get install apache2 -- Fresh install of apache2

If someone is following this guide, don't forget to take backup of your virtual hosts configuration or custom php.ini configuration, if any.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.