Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My machine operating system is Ubuntu 12.04 I tried to implement the all in one openstack solution for development. But ./stack.sh did not succeed. It looks like a package problem for pip. so, I installed iso8601 manually by sudo apt-get install python-iso8601 and sudo pip install iso8601.But the problem remains. Here is a shorten message

/local/bin/pip install --build=/tmp/pip-build.plxx4 -e /opt/stack/oslo.messaging
Obtaining file:///opt/stack/oslo.messaging
  Running setup.py egg_info for package from file:///opt/stack/oslo.messaging
    [pbr] Reusing existing SOURCES.txt
Requirement already satisfied (use --upgrade to upgrade): oslo.config>=1.2.0 in /opt/stack/oslo.config (from oslo.messaging==1.3.0a9.15.g57ebe0d)
Requirement already satisfied (use --upgrade to upgrade): stevedore>=0.14 in /usr/local/lib/python2.7/dist-packages (from oslo.messaging==1.3.0a9.15.g57ebe0d)
Downloading/unpacking iso8601>=0.1.9 (from oslo.messaging==1.3.0a9.15.g57ebe0d)
  Could not find any downloads that satisfy the requirement iso8601>=0.1.9 (from oslo.messaging==1.3.0a9.15.g57ebe0d)
Cleaning up...
No distributions at all found for iso8601>=0.1.9 (from oslo.messaging==1.3.0a9.15.g57ebe0d)
Storing complete log in /home/shisoft/.pip/pip.log
+ exit_trap
+ local r=1
++ jobs -p
+ jobs=
+ [[ -n '' ]]
+ exit 1
shisoft@shisoft-HQStackA:~/devstack$ sudo pip install iso8601
Requirement already satisfied (use --upgrade to upgrade): iso8601 in /usr/lib/python2.7/dist-packages
Cleaning up...
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Ubuntu 12.04 ships python-iso8601 version 0.1.4, whilst in pipy.org you can find version 0.1.10, which fulfills the requirements of the installer.

Also, the log explicitly says you need to override the installed version using --upgrade, so you need to issue:

# pip install --upgrade 8601

After that, compare the output of:

# dpkg -l python-iso8601

and:

# pip list | grep iso8601
share|improve this answer
    
hi, I just tried the first line but it returns Could not find any downloads that satisfy the requirement 8601 and the version of 8601 is still 0.1.4 –  Shisoft Mar 25 at 7:07
    
the first line should be pip install --upgrade iso8601 –  Shisoft Mar 25 at 9:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.