Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to download the source of a package but when I run

root@proxy:~# apt-get source squid3
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Can not find version '3.3.8-1.1' of package 'squid3'
E: Unable to find a source package for squid3

It cannot be found. But when I run apt-cache search squid3 it finds it.

root@proxy:~# apt-cache search squid3
squid-cgi - Full featured Web Proxy cache (HTTP proxy) - control CGI
squid3 - Full featured Web Proxy cache (HTTP proxy)
squid3-common - Full featured Web Proxy cache (HTTP proxy) - common files
squid3-dbg - Full featured Web Proxy cache (HTTP proxy) - Debug symbols
squidclient - Full featured Web Proxy cache (HTTP proxy) - control utility

It works fine with apt-get install squid3 as well. I am using Ubuntu 11.04 server and this is my /etc/apt/sources.list

deb http://old-releases.ubuntu.com/ubuntu natty main restricted universe
deb http://old-releases.ubuntu.com/ubuntu natty-updates main restricted universe
deb http://old-releases.ubuntu.com/ubuntu natty-security main restricted universe
deb http://archive.canonical.com/ubuntu natty partner
deb http://ftp.us.debian.org/debian sid main
deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all
deb http://archive.ubuntu.com/ubuntu natty universe
deb-src http://archive.ubuntu.com/ubuntu natty universe

I've apt-get updated many times. I have tried many different debs and have not found this error any where else.

share|improve this question

1 Answer 1

up vote 8 down vote accepted

The issue here is that your binary packages (deb) is not consistent with your source packages (deb-src). Since squid3 is from sid, add this line:

deb-src http://ftp.us.debian.org/debian sid main

This should fix it

share|improve this answer
1  
Just spotted your error, please read my updated answer. –  md_5 Mar 24 at 6:25
    
That worked perfectly! Thank you so much –  Garrett R Mar 24 at 6:26
    
Awesome, glad I helped –  md_5 Mar 24 at 6:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.