Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have apache 2.2 installed on windows 2003 on a production web server and need to upgrade it to the newest point release.

Apache only provide an installer for windows (or source .. if i want to compile) - if I install over the top of my current install will it work? Or is that going to break things.

Thanks

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Normally, the same branch configuration files are fully compatible.

But you can test you new apache configuration with an other tcp port : read this doc to change binding : apache bind

  1. Install new apache in other directory
  2. Change binding configuration in you new apache
  3. Change your configuration to set modules, files & logs directory etc...
  4. Configtest and Start you new apache and check you site with your new apache
share|improve this answer
    
nice idea, i like it. not the one click answer i was hoping to find - but looks like there isn't a risk free one click upgrade, so accepting this. –  benlumley Aug 26 '09 at 9:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.