Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install lxc 1.0.0 but I get this error when I run this command

I have added the following repos to my sources.lst file

deb http://ppa.launchpad.net/ubuntu-lxc/daily/ubuntu saucy main 
deb-src http://ppa.launchpad.net/ubuntu-lxc/daily/ubuntu saucy main

and ran apt-get install command. BTW my Ubuntu is 13.04 server image. Can someone help me resolve this error?

root@host:/work/user1# apt-get install lxc
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 cgmanager-tests : Depends: cgmanager but it is not going to be installed
 lxc : Depends: cgmanager but it is not going to be installed
       Depends: liblxc1 (= 1.0.1+master~20140324-2000-0ubuntu1~ppa1~saucy1) but it is not going to be installed
       Depends: sysv-rc (>= 2.88dsf-24) but 2.88dsf-13.10ubuntu15 is to be installed or
                file-rc (>= 0.8.16) but it is not installable
       Recommends: uidmap but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
share|improve this question

2 Answers 2

You're running raring but you specified a saucy PPA. This isn't guaranteed to work. And in your case it clearly isn't. Change it to raring. Or better yet, upgrade to 13.10; you're past the support window for 13.04.

share|improve this answer
    
@michael-hampton..lxc 1.0.0 is not officially available on raring repo and I don't think we can officially upgrade to 13.10. Need to make this work on 13.04 :) –  skokal01 Mar 24 at 23:18
    
13.04 is already dead, so it looks like you're going to be upgrading. –  Michael Hampton Mar 24 at 23:19
up vote 0 down vote accepted

I figured out how to install lxc-1.0.0-alpha1 one 13.04 (raring ringtail). I just have to enable raring-backports in my /etc/apt/sources.list and it worked.

The following commands will install lxc-1.0.0-alpha1

apt-get install liblxc0/raring-backports
apt-get install python3-lxc/raring-backports
apt-get install lxc/raring-backports
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.