Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a brand new server containing two identical 3 TB SATA disks. These are in a hardware RAID1 configuration using the onboard Intel RAID controller. The BIOS sees the two disks as 3 TB and the resulting RAID volume is 3TB.

On this server, I am attempting to install Ubuntu Server 12.04 (64-bit). Setup correctly detects the RAID volume, but insists the volume is 801.5 GB. Attempting to change the partition type to GPT does nothing.

If I continue all the way through setup anyway, the system is created with a roughly 800 GB root volume, swap, etc. Running fdisk following this shows the remaining free space on the volume and lets me attempt to partition it. I have not yet tried this, and would really like the entire 3 TB to be part of the root volume. I would also like to avoid attempting to resize the partition after the fact, if at all possible.

share|improve this question
7  
Before you continue, scrap using the Intel Fake RAID controller. Either use a real, dedicated RAID controller or the Linux software RAID. You'll spare yourself a lot of trouble and sorrow. –  SvW Mar 25 at 9:49
add comment

2 Answers 2

Disk controllers with the LBA-32 problem either:

  • limit disk sizes to 2.2TB
  • the modulo of the disk size over 2.2TB (ie, 800GB for a 3TB drive).

Yours is the latter - you need a disk controller that supports LBA-48 for drives larger than 2.2TB.

share|improve this answer
add comment
up vote 1 down vote accepted

I got the drives to work. Here is what I did:

First, I disabled the hardware RAID controller as per suggestion in a comment above. Then, I started the installation in expert mode and completed it normally until the partitioning step. Then, I followed the instructions at https://help.ubuntu.com/12.04/serverguide/advanced-installation.html to set up software RAID.

However, the instructions above have an error in them that at first seems to block progress: once you set a partition to "physical volume for RAID", you cannot set that partition to be bootable. This is a known bug (https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/477167) that has gone unresolved for years now. Thus, one of the steps in the guide that refers to setting the / partition to bootable can't be completed.

Fortunately, just ignoring this instruction worked for me. Additionally, I set up a reserved empty 1MB partition near the beginning set to "reserved BIOS boot area" for grub's use. With this setup, it seems grub was able to correctly set everything up and after finishing software RAID setup as per the installation instructions, the server was able to successfully install and boot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.