Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have compiled python 3.3.5 from source in the /opt folder as follows:

yum install sqlite-devel
./configure --prefix=/opt/python3
make
make install
ln -s /opt/python3/bin/python3 /usr/bin/python3

I then installed easy install as follows:

wget https://pypi.python.org/packages/source/s/setuptools/setuptools-3.3.tar.gz
tar xvf setuptools-3.3.tar.gz
cd setuptools-3.3
cat ez_setup.py | /opt/python3/bin/python3.3

Finally I did:

cat ez_setup.py | /opt/python3/bin/py
/opt/python3/bin/easy_install sphinx
/opt/python3/bin/easy_install pysqlite

Which gives me:

  File "setup.py", line 85
    print "Is sphinx installed? If not, try 'sudo easy_install sphinx'."

I have also tried compiling pysqlite from source which gives me the same error.

Sphinx binaries are in /opt/python3/bin/sphinx-*

I have tried copying them to /usr/bin with no luck.

Does anyone know what might be wrong?

share|improve this question
    
Is /opt/python3/bin at the head of your $PATH? –  MadHatter Mar 26 at 11:49
    
@MadHatter added /opt/python3/bin to path with the same result –  user2284355 Mar 26 at 12:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.