Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a server running CentOS release 5.5 (Final) The server hosts a few Drupal(6.3) websites.

I need to upgrade php from 5.1 to 5.3 as I need to install a new Drupal 7.26 site.

so this is what I did,

  1. php -v PHP 5.1.6 (cli) (built: Mar 31 2010 02:44:37)

  2. yum list php* to list the available php packages that can be installed

  3. yum list installed php* to will list all php packages installed on the server php.i386 5.1.6-27.el5
    php-cli.i386 5.1.6-27.el5
    php-common.i386 5.1.6-27.el5
    php-devel.i386 5.1.6-27.el5
    php-gd.i386 5.1.6-27.el5
    php-imap.i386 5.1.6-27.el5
    php-ldap.i386 5.1.6-27.el5
    php-mbstring.i386 5.1.6-27.el5
    php-mysql.i386 5.1.6-27.el5
    php-pdo.i386 5.1.6-27.el5
    php-pear.noarch 1:1.4.9-6.el5
    php-pear-Auth-SASL.noarch 1.0.4-1.el5
    php-pear-Mail.noarch 1.1.14-5.el5.1
    php-pear-Net-SMTP.noarch 1.4.2-1.el5
    php-pear-Net-Socket.noarch 1.0.8-1.el5.centos
    php-snmp.i386 5.1.6-27.el5
    php-xml.i386 5.1.6-27.el5

  4. Remove PHP5.1: yum remove php.i386 php-cli.i386 php-common.i386 php-devel.i386 php-gd.i386 php-imap.i386 php-ldap.i386 php-mbstring.i386 php-mysql.i386 php-pdo.i386 php-snmp.i386 php-xml.i386

  5. This removed all dependency’s as well eg php-pear.noarch 1:1.4.9-6.el5
    php-pear-Auth-SASL.noarch 0:1.0.4-1.el5
    php-pear-Mail.noarch 0:1.1.14-5.el5.1 php-pear-Net-SMTP.noarch 0:1.4.2-1.el5
    php-pear-Net-Socket.noarch 0:1.0.8-1.el5.centos

  6. Install all of the above packages. yum install php53.i386 php53-cli.i386 php53-common.i386 php53-devel.i386 php53-gd.i386 php53-imap.i386 php53-ldap.i386 php53-mbstring.i386 php53-mysql.i386 php53-pdo.i386 php53-snmp.i386 php53-xml.i386

  7. This installed the following dependency libXpm.i386 0:3.5.5-3

  8. restart nginx

  9. php -v PHP 5.3.3 (cli) (built: Dec 10 2013 22:20:06) HAPPY Days....

I then set up a new website using drupal 7.26

However when I go to install the site I get this error

Your PHP installation is too old. Drupal requires at least PHP 5.2.4. See the system requirements page for more information.

Did I miss some thing when I installed PHP5.3?

All the other website are still working so now I am not sure what version I am running!!

share|improve this question
What says a php page with the phpinfo() function? – AndrewQ Mar 26 '14 at 13:57
PHP Version 5.1.6 - now I am very confused..... – mnocter Mar 26 '14 at 14:12
Did you restarted the http server? – AndrewQ Mar 26 '14 at 14:14
I restarted nginx and tomcat. – mnocter Mar 26 '14 at 14:19
It seems that the configuration of php5.1 and php5.3 differs in nginx. If I have understand well, you're using cgi: nginx requires php-fpm, that is available on the 'Remi' repo. – AndrewQ Mar 26 '14 at 15:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.