Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Rails 4 app and I want to deploy it to my Linode and I'm struggling a lot to get this working. I followed all the basic instructions from the Linode guides, also, installed all the dependencies for my app, configured the database, created a deployer user and performed all the configuration advised by the Linode guides. I have even installed Postgres and set up my user and BD.

Also, I have resolved all the dependencies of my application (Ruby or not) and all the ruby dependencies were resolved via Bundler.

I tried everything based on this screencast http://railscasts.com/episodes/335-deploying-to-a-vps. I have and also pointed my domain address to the machine but the app itself is not routing to this address and I really need it because the client wants to see the page in production ASAP.

When I log into my Linode as the deployer (non-admin) user and run the ls command, it returns me this:

apps database.yml public

and within public I have:

example.com somosprofessores.org

which correspond the base sample app that already came with my Linode and my app itself, the Rails app root.

Unfortunately, the Linode support can't help me with this, while the Rails deploy guide is so very incomplete and I really need to get this done.

Please help me.

Tech specs:

Ubuntu 13.10 Ruby 2.0 Rails 4 PostgreSQL 9.1 Nginx

share|improve this question
    
Did you get this worked out by chance? –  James Skemp Aug 7 '14 at 11:30
    
@JamesSkemp No, I gave up –  rodrigoalves Aug 8 '14 at 21:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.